# CVE-2026-49328: Apache Fesod (Incubating): Improper validation of user-supplied URLs leading to SSRF

> Attackers can trigger outbound requests to internal resources via malicious image URLs in Apache Fesod, requiring an upgrade to mitigate.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2026
- **Updated:** 1 Jun 2026
- **Also known as:** GHSA-vqc2-c9jh-3jjv

## What is CVE-2026-49328?

CVE-2026-49328 is a medium-severity server-side request forgery vulnerability in Apache Fesod (Incubating), published on 1 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Server-Side Request Forgery (SSRF) in the UrlImageConverter component of Apache Fesod (Incubating) fesod-sheet before 2.0.2-incubating allows attackers to cause outbound network requests to internal or otherwise restricted resources via a user-supplied image URL. Users are recommended to upgrade to version 2.0.2-incubating, which fixes this issue.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-49328?

2 open source packages ship an affected version, including org.apache.fesod:fesod-sheet. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.fesod:fesod-sheet` | Maven | All versions | 2.0.2-incubating |
| `org.apache.fesod:fesod-sheet` | Maven | All versions | 2.0.2-incubating |

Products: Apache Fesod.

## How do I fix CVE-2026-49328?

Upgrade org.apache.fesod:fesod-sheet to 2.0.2-incubating or later.

## Is CVE-2026-49328 being exploited?

There is no known exploitation of CVE-2026-49328 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49328 and fix it if it is affected.

What it is: CVE-2026-49328 is a medium-severity server-side request forgery vulnerability in Apache Fesod (Incubating), published on 1 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49328 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.fesod:fesod-sheet (Maven): affected all versions; fixed in 2.0.2-incubating
- org.apache.fesod:fesod-sheet (Maven): affected all versions; fixed in 2.0.2-incubating

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49328/ (Markdown: https://insights.sbomify.com/CVE-2026-49328/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49328
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49328
- OSV: https://osv.dev/vulnerability/CVE-2026-49328

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49328/
Summaries are generated and may contain mistakes; the official description above is the record.
