# CVE-2026-49342: YARD static cache reads raw traversal paths before router sanitization

> Attackers can read arbitrary HTML files outside the intended directory if YARD is configured with a document root, due to premature path resolution.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-49342, GHSA-pxcc-8665-phx8, OESA-2026-2851, OESA-2026-2852, UBUNTU-CVE-2026-49342

## What is CVE-2026-49342?

CVE-2026-49342 is a medium-severity path traversal vulnerability in lsegal yard, published on 19 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

YARD is a documentation generation tool for the Ruby programming language. Prior to version 0.9.44, YARD's static cache lookup reads a request path before the router's path cleanup runs. When a server is configured with a document root, a traversal path such as `/../yard-cache-secret.html` is joined against that root and can return a readable sibling `.html` file outside the intended static tree. Version 0.9.44 patches the issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-49342?

2 open source packages ship an affected version, including yard.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yard` | RubyGems | All versions | 0.9.44 |
| `yard` | RubyGems | All versions | 0.9.44 |

## How do I fix CVE-2026-49342?

Upgrade yard to 0.9.44 or later.

## Is CVE-2026-49342 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49342 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49342 and fix it if it is affected.

What it is: CVE-2026-49342 is a medium-severity path traversal vulnerability in lsegal yard, published on 19 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49342 exists.

Affected packages and fixed versions:
- yard (RubyGems): affected all versions; fixed in 0.9.44
- yard (RubyGems): affected all versions; fixed in 0.9.44

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49342/ (Markdown: https://insights.sbomify.com/CVE-2026-49342/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49342
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49342
- OSV: https://osv.dev/vulnerability/CVE-2026-49342

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49342/
Summaries are generated and may contain mistakes; the official description above is the record.
