# CVE-2026-49352: 9Router: Hardcoded Default fallback JWT Secret Allows Authentication Bypass

> Attackers can bypass authentication and take over accounts by forging JWT tokens using a hardcoded default secret when the environment variable is unset.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 16 Jul 2026
- **Also known as:** GHSA-jphh-m39h-6gwx

## What is CVE-2026-49352?

CVE-2026-49352 is a critical vulnerability in decolua 9router, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

9Router is an AI router & token saver. From 0.2.21 until 0.4.44, 9Router used the hardcoded fallback JWT secret 9router-default-secret-change-me in src/app/api/auth/login/route.js, src/middleware.js, and later src/lib/auth/dashboardSession.js, allowing attackers to forge an auth_token cookie when JWT_SECRET was unset. This issue is fixed in version 0.4.44

Weakness: CWE-798 (Use of Hard-coded Credentials)

## Which versions are affected by CVE-2026-49352?

2 open source packages ship an affected version, including 9router.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `9router` | npm | From 0.2.21 | 0.4.45 |
| `9router` | npm | From 0.2.21 | 0.4.45 |

## How do I fix CVE-2026-49352?

Upgrade 9router to 0.4.45 or later.

## Is CVE-2026-49352 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49352 exists.

Public exploit code:

- Exploitability PoC for CVE-2026-49352 (9router Hardcoded JWT Secret Authentication Bypass) (github_poc): https://github.com/covepseng/cve-2026-49352-poc

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49352 and fix it if it is affected.

What it is: CVE-2026-49352 is a critical vulnerability in decolua 9router, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49352 exists.

Affected packages and fixed versions:
- 9router (npm): affected from 0.2.21; fixed in 0.4.45
- 9router (npm): affected from 0.2.21; fixed in 0.4.45

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49352/ (Markdown: https://insights.sbomify.com/CVE-2026-49352/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49352
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49352
- OSV: https://osv.dev/vulnerability/CVE-2026-49352

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49352/
Summaries are generated and may contain mistakes; the official description above is the record.
