# CVE-2026-49358: PhpWeasyPrint vulnerable to arbitrary file deletion at shutdown via public $temporaryFiles

> Attackers can delete arbitrary files by injecting paths into a public array, affecting applications using PhpWeasyPrint for PDF generation.

- **Severity:** Low 3.0 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-5g9f-cwwg-4p8g

## What is CVE-2026-49358?

CVE-2026-49358 is a low-severity path traversal vulnerability in pontedilana php-weasyprint, published on 19 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

PhpWeasyPrint is a PHP library allowing PDF generation from a URL or an HTML page. Prior to version 2.6.0, `AbstractGenerator::$temporaryFiles` is a public array, and `removeTemporaryFiles()` — invoked from `__destruct()` and from a registered shutdown function — calls `unlink()` on every entry without verifying that the path is contained within the temporary folder. Any code holding a reference to a generator instance can push an arbitrary path into the array and have it deleted on script shutdown. This mirrors the KnpLabs/snappy issue GHSA-87qc-37cw-84h4. PhpWeasyPrint version 2.6.0 contains a patch for the issue.

Weakness: CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2026-49358?

2 open source packages ship an affected version, including pontedilana/php-weasyprint.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pontedilana/php-weasyprint` | Packagist | All versions | 2.6.0 |
| `pontedilana/php-weasyprint` | Packagist | All versions | 2.6.0 |

## How do I fix CVE-2026-49358?

Upgrade pontedilana/php-weasyprint to 2.6.0 or later.

## Is CVE-2026-49358 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49358 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49358 and fix it if it is affected.

What it is: CVE-2026-49358 is a low-severity path traversal vulnerability in pontedilana php-weasyprint, published on 19 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49358 exists.

Affected packages and fixed versions:
- pontedilana/php-weasyprint (Packagist): affected all versions; fixed in 2.6.0
- pontedilana/php-weasyprint (Packagist): affected all versions; fixed in 2.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49358/ (Markdown: https://insights.sbomify.com/CVE-2026-49358/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49358
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49358
- OSV: https://osv.dev/vulnerability/CVE-2026-49358

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49358/
Summaries are generated and may contain mistakes; the official description above is the record.
