{"answers":{"affected":"2 open source packages ship an affected version, including pontedilana/php-weasyprint.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49359 exists.","fix":"Upgrade pontedilana/php-weasyprint to 2.6.0 or later.","what":"CVE-2026-49359 is a medium-severity server-side request forgery vulnerability in pontedilana php-weasyprint, published on 19 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-49359 and fix it if it is affected.\n\nWhat it is: CVE-2026-49359 is a medium-severity server-side request forgery vulnerability in pontedilana php-weasyprint, published on 19 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49359 exists.\n\nAffected packages and fixed versions:\n- pontedilana/php-weasyprint (Packagist): affected all versions; fixed in 2.6.0\n- pontedilana/php-weasyprint (Packagist): affected all versions; fixed in 2.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-49359/ (Markdown: https://insights.sbomify.com/CVE-2026-49359/index.md)","id":"CVE-2026-49359","markdown":"https://insights.sbomify.com/CVE-2026-49359/index.md","name":"CVE-2026-49359","record":{"aliases":["GHSA-x8g9-h984-pc36"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP PDF generation library","requires_auth":"low_privilege","summary":"Attackers can exploit the attachment option to perform Server-Side Request Forgery and read local files via PHP stream wrappers.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"PhpWeasyPrint is a PHP library allowing PDF generation from a URL or an HTML page. Prior to version 2.6.0, `pontedilana/php-weasyprint` fetches the content of option values server-side via `file_get_contents()` when the value looks like a URL, without restricting the URL scheme. The `attachment` option of `Pdf` is the reachable sink: any value that passes `isOptionUrl()` (`filter_var(..., FILTER_VALIDATE_URL)`) is downloaded by the PHP process and embedded into the generated PDF. Because `FILTER_VALIDATE_URL` accepts `http`, `https`, `ftp`, `file` and PHP stream wrappers such as `php://`, an attacker who can influence the `attachment` value reaches both a **Server-Side Request Forgery** primitive (e.g. internal HTTP endpoints, cloud metadata) and a local file disclosure primitive (`file://`, `php://filter/...`), with the fetched bytes exfiltrated as a PDF attachment. This is the same class of issue KnpLabs/snappy patched for its `xsl-style-sheet` option in GHSA-c5fp-p67m-gq56. The library is documented as a one-to-one substitute for KnpLabs/snappy and shares the same code shape. PhpWeasyPrint version 2.6.0 contains a patch for the issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"PhpWeasyPrint vulnerable to SSRF and local file disclosure via the attachment option","id":"CVE-2026-49359","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"Recce server has unauthenticated SQL execution that allows local file read/write through DuckDB","id":"CVE-2026-49360"},"packages":[{"ecosystem":"Packagist","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"pontedilana/php-weasyprint","purl":null,"source":"GHSA-x8g9-h984-pc36"},{"ecosystem":"Packagist","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"pontedilana/php-weasyprint","purl":"pkg:composer/pontedilana/php-weasyprint","source":"GHSA-x8g9-h984-pc36"}],"prev":{"headline":"PhpWeasyPrint vulnerable to arbitrary file deletion at shutdown via public $temporaryFiles","id":"CVE-2026-49358"},"products":["php-weasyprint"],"published":"2026-06-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-23","vendors":["pontedilana"]},"summary":"Attackers can exploit the attachment option to perform Server-Side Request Forgery and read local files via PHP stream wrappers.","url":"https://insights.sbomify.com/CVE-2026-49359/"}