# CVE-2026-49360: Recce server has unauthenticated SQL execution that allows local file read/write through DuckDB

> Unauthenticated SQL execution in Recce allows attackers to read and write local files via DuckDB primitives when exposed without authentication.

- **Severity:** High 7.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:L/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-rh62-j648-g5qc, PYSEC-2026-3049

## What is CVE-2026-49360?

CVE-2026-49360 is a high-severity SQL injection vulnerability in DataRecce recce, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Recce is a data-validation toolkit for enhanced dbt (data build tool) PR review. Prior to version 1.50.0, OSS server deployments that expose the server to an untrusted network without authentication are vulnerable to unauthenticated SQL execution through the query run API. When Recce is configured with a DuckDB-backed project, an attacker can use DuckDB filesystem primitives to read and write files accessible to the Recce server process. The impact depends on how Recce is deployed, but may include disclosure of local files, tampering with Recce/dbt artifacts, modification of browser-served static files leading to stored XSS, and modification of application files if those paths are writable. If Recce is run as root, file access occurs with root privileges inside that host or container. This issue has been patched in Recce `v1.50.0`. Users should upgrade to Recce `v1.50.0` or later. The patch restricts unsafe file read/write behavior for DuckDB-backed query execution and hardens the affected query path. Other warehouse adapters have also been reviewed for similar exposure. Users who cannot upgrade immediately should avoid exposing `recce server` to the public internet or any untrusted network. Recommended mitigations include enabling authentication or placing Recce behind an authenticated reverse proxy/VPN, running Recce as a non-root user, using a read-only application filesystem where possible, and ensuring that sensitive files or credentials are not available to the Recce process.

Weakness: CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2026-49360?

3 open source packages ship an affected version, including recce.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `recce` | PyPI | All versions | 1.50.0 |
| `recce` | PyPI | All versions | 1.50.0 |
| `recce` | PyPI | All versions | 1.50.0 |

## How do I fix CVE-2026-49360?

Upgrade recce to 1.50.0 or later.

## Is CVE-2026-49360 being exploited?

There is no known exploitation of CVE-2026-49360 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49360 and fix it if it is affected.

What it is: CVE-2026-49360 is a high-severity SQL injection vulnerability in DataRecce recce, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49360 in the wild and no public exploit code.

Affected packages and fixed versions:
- recce (PyPI): affected all versions; fixed in 1.50.0
- recce (PyPI): affected all versions; fixed in 1.50.0
- recce (PyPI): affected all versions; fixed in 1.50.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49360/ (Markdown: https://insights.sbomify.com/CVE-2026-49360/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49360
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49360
- OSV: https://osv.dev/vulnerability/CVE-2026-49360

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49360/
Summaries are generated and may contain mistakes; the official description above is the record.
