CVE-2026-49361 Apache Fluss Netty Frame Decoder Memory Exhaustion Vulnerability
Unauthenticated attackers can cause denial of service in Apache Fluss by exhausting JVM heap memory via crafted network frames.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-49361?
CVE-2026-49361 is a high-severity denial of service vulnerability in Apache Fluss (incubating), published on 1 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache Fluss versions prior to 0.9.1 configure the Netty LengthFieldBasedFrameDecoder with Integer.MAX_VALUE as the maximum frame length, allowing unauthenticated remote attackers to exhaust JVM heap memory on TabletServer and CoordinatorServer by sending specially crafted frame headers, resulting in denial of service.
This issue affects Apache Fluss (incubating): 0.8.0 and 0.9.0.
Users are recommended to upgrade to version 0.9.1, which fixes the issue.
Which versions are affected by CVE-2026-49361?
2 open source packages ship an affected version, including org.apache.fluss:fluss-common. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.fluss:fluss-common Maven | From 0.8.0-incubating-rc1 | 0.9.1-incubating |
org.apache.fluss:fluss-common Maven | From 0.8.0-incubating-rc1 | 0.9.1-incubating |
Products include Apache Fluss.
How do I fix CVE-2026-49361?
Upgrade org.apache.fluss:fluss-common to 0.9.1-incubating or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-49361 being exploited?
There is no known exploitation of CVE-2026-49361 in the wild and no public exploit code.
Sources
Also known as GHSA-4c39-fwgj-4vq7.