# CVE-2026-49361: Apache Fluss Netty Frame Decoder Memory Exhaustion Vulnerability

> Unauthenticated attackers can cause denial of service in Apache Fluss by exhausting JVM heap memory via crafted network frames.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2026
- **Updated:** 1 Jun 2026
- **Also known as:** GHSA-4c39-fwgj-4vq7

## What is CVE-2026-49361?

CVE-2026-49361 is a high-severity denial of service vulnerability in Apache Fluss (incubating), published on 1 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Fluss versions prior to 0.9.1 configure the Netty LengthFieldBasedFrameDecoder with Integer.MAX_VALUE as the maximum frame length, allowing unauthenticated remote attackers to exhaust JVM heap memory on TabletServer and CoordinatorServer by sending specially crafted frame headers, resulting in denial of service.

This issue affects Apache Fluss (incubating): 0.8.0 and 0.9.0.

Users are recommended to upgrade to version 0.9.1, which fixes the issue.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-49361?

2 open source packages ship an affected version, including org.apache.fluss:fluss-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.fluss:fluss-common` | Maven | From 0.8.0-incubating-rc1 | 0.9.1-incubating |
| `org.apache.fluss:fluss-common` | Maven | From 0.8.0-incubating-rc1 | 0.9.1-incubating |

Products: Apache Fluss.

## How do I fix CVE-2026-49361?

Upgrade org.apache.fluss:fluss-common to 0.9.1-incubating or later.

## Is CVE-2026-49361 being exploited?

There is no known exploitation of CVE-2026-49361 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49361 and fix it if it is affected.

What it is: CVE-2026-49361 is a high-severity denial of service vulnerability in Apache Fluss (incubating), published on 1 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49361 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.fluss:fluss-common (Maven): affected from 0.8.0-incubating-rc1; fixed in 0.9.1-incubating
- org.apache.fluss:fluss-common (Maven): affected from 0.8.0-incubating-rc1; fixed in 0.9.1-incubating

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49361/ (Markdown: https://insights.sbomify.com/CVE-2026-49361/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49361
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49361
- OSV: https://osv.dev/vulnerability/CVE-2026-49361

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49361/
Summaries are generated and may contain mistakes; the official description above is the record.
