CVE-2026-49362 Missing authorization in Apache ActiveMQ Artemis

High 7.5 Published Updated

Unauthenticated attackers can create arbitrary durable queues via the CORE protocol, causing unauthorized state changes and potential denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-49362?

CVE-2026-49362 is a high-severity missing authorization vulnerability in Apache ActiveMQ Artemis, published on 10 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An unauthenticated remote attacker can create arbitrary durable queues via the CORE protocol, leading to unauthorized broker state manipulation and potential denial of service.

This issue affects Apache Artemis: from 2.50.0 through 2.56.0; Apache ActiveMQ Artemis: from 1.0.0 through 2.44.0.

Users are recommended to upgrade to version 2.57.0, which fixes the issue.

Weakness: CWE-306

Which versions are affected by CVE-2026-49362?

It affects 1 product.

Products include Apache Artemis.

How do I fix CVE-2026-49362?

Upgrade to a fixed version.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-49362 being exploited?

There is no known exploitation of CVE-2026-49362 in the wild and no public exploit code.

Sources

Also known as GHSA-593h-2v8w-vxpx.

Is CVE-2026-49362 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free