CVE-2026-49364 Information disclosure in Apache ActiveMQ Artemis

Critical 9.1 Published Updated

An unauthenticated attacker can capture cluster administrative credentials during the initial handshake, potentially leading to unauthorized access.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-49364?

CVE-2026-49364 is a critical vulnerability in Apache ActiveMQ Artemis, published on 10 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An unauthenticated network-adjacent attacker can leverage discovery to capture cluster administrative credentials during the initial cluster connection handshake.

This issue affects Apache Artemis: from 2.50.0 through 2.56.0; Apache ActiveMQ Artemis: from 1.0.0 through 2.44.0.

Users are recommended to upgrade to version 2.57.0, which fixes the issue.

Weakness: CWE-306

Which versions are affected by CVE-2026-49364?

It affects 1 product.

Products include Apache Artemis.

How do I fix CVE-2026-49364?

Upgrade to a fixed version.

Is CVE-2026-49364 being exploited?

There is no known exploitation of CVE-2026-49364 in the wild and no public exploit code.

Sources

Also known as GHSA-fjwp-v5xg-5q39.

Is CVE-2026-49364 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free