# CVE-2026-49365: Apache Camel-Netty-HTTP: The muteException consumer option defaulted to false, so a processing error returned the full Java stack trace in the HTTP response body

> Unauthenticated attackers can obtain sensitive internal information, including stack traces and credentials, by triggering processing errors in Apache Camel Netty HTTP endpoints.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2026
- **Updated:** 7 Jul 2026
- **Also known as:** GHSA-42q5-xw42-xf9g

## What is CVE-2026-49365?

CVE-2026-49365 is a medium-severity vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Generation of Error Message Containing Sensitive Information vulnerability in Apache Camel Netty HTTP component.

The camel-netty-http HTTP server consumer exposes a muteException option that controls what is returned to the client when a route processing error occurs. This option defaulted to false because the backing field was an uninitialised primitive boolean (Java's default of false), whereas the other Camel HTTP server components (camel-http / camel-jetty / camel-servlet and camel-platform-http) default it to true. With muteException=false, when a request triggers an exception during route processing the consumer writes the full Throwable stack trace into the HTTP response body as text/plain (via DefaultNettyHttpBinding) instead of returning an empty body. Any unauthenticated client that can reach the endpoint and cause a processing error - for example by sending a malformed request body, an invalid parameter, or otherwise triggering a route-internal failure - therefore receives a complete Java stack trace. Such a stack trace can disclose sensitive internal information, including credentials embedded in exception messages, internal host names and IP addresses, filesystem paths, dependency and version details, database and class names, and the application's internal structure, which an attacker can use to plan further attacks.
This issue affects Apache Camel: from 4.0.0 before 4.14.8, from 4.15.0 before 4.18.3, from 4.19.0 before 4.21.0.

Users are recommended to upgrade to version 4.21.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.8. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.3. For deployments that cannot upgrade immediately, set muteException=true explicitly on the camel-netty-http consumer (for example netty-http: http://0.0.0.0:8080/api?muteException=true , or globally via the camel.component.netty-http.configuration.mute-exception=true property), so that processing errors no longer return the stack trace to the client.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2026-49365?

6 open source packages ship an affected version, including org.apache.camel:camel-netty-http. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-netty-http` | Maven | From 4.0.0 | 4.14.8 |
| `org.apache.camel:camel-netty-http` | Maven | From 4.0.0 | 4.14.8 |
| `org.apache.camel:camel-netty-http` | Maven | From 4.15.0 | 4.18.3 |
| `org.apache.camel:camel-netty-http` | Maven | From 4.15.0 | 4.18.3 |
| `org.apache.camel:camel-netty-http` | Maven | From 4.19.0 | 4.21.0 |
| `org.apache.camel:camel-netty-http` | Maven | From 4.19.0 | 4.21.0 |

Products: Apache Camel.

## How do I fix CVE-2026-49365?

Upgrade org.apache.camel:camel-netty-http to a fixed version for your release line: 4.14.8, 4.18.3 or 4.21.0.

## Is CVE-2026-49365 being exploited?

There is no known exploitation of CVE-2026-49365 in the wild and no public exploit code.

Public exploit code:

- PoC reproducer for CVE-2026-49365 (Apache Camel camel-netty-http / camel-undertow): muteException defaults to false, so an uncaught exception's full Java stack trace is returned to the HTTP client (CWE-209). Fixed in 4.14.8/4.18.3/4.21.0. (github_poc): https://github.com/oscerd/CVE-2026-49365

## Other vulnerabilities in Apache Camel

- [CVE-2026-33453](https://insights.sbomify.com/CVE-2026-33453/): Apache camel-coap allows header injection that can lead to remote code execution (critical 10.0)
- [CVE-2026-40453](https://insights.sbomify.com/CVE-2026-40453/): Apache Camel has an incomplete fix for CVE-2025-27636 (critical 9.9)
- [CVE-2026-80351](https://insights.sbomify.com/CVE-2026-80351/): Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod (critical 9.8)
- [CVE-2026-80352](https://insights.sbomify.com/CVE-2026-80352/): Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects (critical 9.8)
- [CVE-2026-71300](https://insights.sbomify.com/CVE-2026-71300/): Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49365 and fix it if it is affected.

What it is: CVE-2026-49365 is a medium-severity vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49365 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.camel:camel-netty-http (Maven): affected from 4.0.0; fixed in 4.14.8
- org.apache.camel:camel-netty-http (Maven): affected from 4.0.0; fixed in 4.14.8
- org.apache.camel:camel-netty-http (Maven): affected from 4.15.0; fixed in 4.18.3
- org.apache.camel:camel-netty-http (Maven): affected from 4.15.0; fixed in 4.18.3
- org.apache.camel:camel-netty-http (Maven): affected from 4.19.0; fixed in 4.21.0
- org.apache.camel:camel-netty-http (Maven): affected from 4.19.0; fixed in 4.21.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49365/ (Markdown: https://insights.sbomify.com/CVE-2026-49365/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49365
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49365
- OSV: https://osv.dev/vulnerability/CVE-2026-49365

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49365/
Summaries are generated and may contain mistakes; the official description above is the record.
