# CVE-2026-49400: October CMS: PHP Object Injection via Backend Widget Session Storage

> Attackers can achieve arbitrary code execution via PHP object injection in October CMS when Safe Mode is enabled.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-2ff2-mx52-q8wp

## What is CVE-2026-49400?

CVE-2026-49400 is a low-severity unsafe deserialization vulnerability in octobercms october, published on 14 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

October System provides the system module for October Content Management System. Prior to versions 3.7.17 and 4.2.21, the backend `SessionMaker` trait stored widget session state as `base64(serialize(...))` and consumed it with `unserialize()` without an `allowed_classes` restriction. Any code path that could write to a `widget.*` session key with attacker-controlled bytes could trigger PHP object injection the next time the widget read its session state, allowing instantiation of arbitrary classes and reachable PHP gadget chains. This issue only affects installations running with `cms.safe_mode` enabled. Safe Mode is a niche opt-in feature, primarily used for demo installations and multi-tenant or shared-editor scenarios where untrusted users are deliberately granted access to the CMS markup editor. In standard production deployments Safe Mode is off, backend access is restricted to trusted administrators, and a markup editor can already execute arbitrary PHP directly. The session-write path that reaches this sink is gated by the Safe Mode sandbox, so installations without Safe Mode enabled are not exposed. Scope of impact is narrow even with Safe Mode enabled. The standard backend code paths that populate widget session state (search terms, sort options, selected IDs, filter values) wrap the input inside a known array shape before serializing, so user-supplied values never reach `unserialize()` as a controllable serialized payload. Exploitation requires the Safe Mode session-write path together with a suitable PHP gadget chain reachable from the installed dependency set. The hardening below removes the underlying object-injection sink so the class of issue is closed off regardless. The vulnerability has been patched in v3.7.17 and v4.2.21. Two changes were applied. `Backend\Traits\SessionMaker` now stores widget session state as plain JSON instead of `base64(serialize(...))`, eliminating the object-injection sink entirely for new writes. Reads transparently fall back to the legacy format for one upgrade cycle so existing sessions retain their saved widget state. The legacy `unserialize()` fallback path now sets `allowed_classes => false`, so even values written before the upgrade cannot instantiate objects. As a workaround, restrict CMS markup editing access to fully trusted administrators only, the standard October CMS recommendation for any deployment.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-49400?

4 open source packages ship an affected version, including october/system.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `october/system` | Packagist | All versions | 3.7.17 |
| `october/system` | Packagist | All versions | 3.7.17 |
| `october/system` | Packagist | From 4.0.0 | 4.2.23 |
| `october/system` | Packagist | From 4.0.0 | 4.2.23 |

## How do I fix CVE-2026-49400?

Upgrade october/system to a fixed version for your release line: 3.7.17 or 4.2.23.

## Is CVE-2026-49400 being exploited?

There is no known exploitation of CVE-2026-49400 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49400 and fix it if it is affected.

What it is: CVE-2026-49400 is a low-severity unsafe deserialization vulnerability in octobercms october, published on 14 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49400 in the wild and no public exploit code.

Affected packages and fixed versions:
- october/system (Packagist): affected all versions; fixed in 3.7.17
- october/system (Packagist): affected all versions; fixed in 3.7.17
- october/system (Packagist): affected from 4.0.0; fixed in 4.2.23
- october/system (Packagist): affected from 4.0.0; fixed in 4.2.23

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49400/ (Markdown: https://insights.sbomify.com/CVE-2026-49400/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49400
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49400
- OSV: https://osv.dev/vulnerability/CVE-2026-49400

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49400/
Summaries are generated and may contain mistakes; the official description above is the record.
