CVE-2026-49432 Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp: STOMP negative content-length enables denial of service
Remote unauthenticated attackers can cause denial of service in Apache ActiveMQ STOMP connectors by sending negative content-length headers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-49432?
CVE-2026-49432 is a high-severity denial of service vulnerability in Apache Activemq, published on 30 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Input Validation vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp.
A remote unauthenticated peer that can reach an exposed STOMP connector can trigger denial-of-service behavior by sending a negative content-length. For the NIO STOMP transport, an attacker can keep streaming body bytes and grow the per-connection command buffer beyond configured limits to cause OOM. For the blocking STOMP protocol, an error will instead force abnormal transport exception handling for the affected connection and closure. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Stomp: before 5.19.8, from 6.0.0 before 6.2.7.
Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
Weakness: CWE-20
Which versions are affected by CVE-2026-49432?
1 open source package ship an affected version, including activemq. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
activemq Bitnami | All versions | 5.19.8, 6.2.7 |
Products include Apache Activemq.
How do I fix CVE-2026-49432?
Upgrade activemq to a fixed version for your release line: 5.19.8 or 6.2.7.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-49432 being exploited?
There is no known exploitation of CVE-2026-49432 in the wild and no public exploit code.
Other vulnerabilities in Apache Activemq
Sources
Also known as BIT-activemq-2026-49432, DEBIAN-CVE-2026-49432, GHSA-xjwq-9jw5-jf7w, MINI-8v8q-vm55-242c, MINI-q52p-jmg3-jqcg, MINI-rqrf-65pr-88qh and 2 more.