# CVE-2026-49432: Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp: STOMP negative content-length enables denial of service

> Remote unauthenticated attackers can cause denial of service in Apache ActiveMQ STOMP connectors by sending negative content-length headers.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jun 2026
- **Updated:** 30 Jun 2026
- **Also known as:** BIT-activemq-2026-49432, DEBIAN-CVE-2026-49432, GHSA-xjwq-9jw5-jf7w, MINI-8v8q-vm55-242c, MINI-q52p-jmg3-jqcg, MINI-rqrf-65pr-88qh, MINI-wwxv-4rc4-4m8p, UBUNTU-CVE-2026-49432

## What is CVE-2026-49432?

CVE-2026-49432 is a high-severity denial of service vulnerability in Apache Activemq, published on 30 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp.

A remote unauthenticated peer that can reach an exposed STOMP connector can trigger denial-of-service behavior by sending a negative content-length. For the NIO STOMP transport, an attacker can keep streaming body bytes and grow the per-connection command buffer beyond configured limits to cause OOM. For the blocking STOMP protocol, an error will instead force abnormal transport exception handling for the affected connection and closure.
This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Stomp: before 5.19.8, from 6.0.0 before 6.2.7.

Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-49432?

1 open source package ship an affected version, including activemq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activemq` | Bitnami | All versions | 5.19.8, 6.2.7 |

Products: Apache Activemq.

## How do I fix CVE-2026-49432?

Upgrade activemq to a fixed version for your release line: 5.19.8 or 6.2.7.

## Is CVE-2026-49432 being exploited?

There is no known exploitation of CVE-2026-49432 in the wild and no public exploit code.

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49432 and fix it if it is affected.

What it is: CVE-2026-49432 is a high-severity denial of service vulnerability in Apache Activemq, published on 30 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49432 in the wild and no public exploit code.

Affected packages and fixed versions:
- activemq (Bitnami): affected all versions; fixed in 5.19.8, 6.2.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49432/ (Markdown: https://insights.sbomify.com/CVE-2026-49432/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49432
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49432
- OSV: https://osv.dev/vulnerability/CVE-2026-49432

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49432/
Summaries are generated and may contain mistakes; the official description above is the record.
