# CVE-2026-49439: OpenRemote read-only asset users can write predicted datapoints

> Attackers with read-only asset privileges can write predicted datapoints in OpenRemote, allowing unauthorized data modification.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-xj53-j257-hxvg

## What is CVE-2026-49439?

CVE-2026-49439 is a medium-severity missing authorization vulnerability in openremote, published on 11 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenRemote is an open-source internet-of-things platform. Prior to version 1.24.1, the predicted datapoint write endpoint allows users with only `read:assets` privileges to write predicted datapoints. Version 1.24.1 fixes the issue.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-49439?

2 open source packages ship an affected version, including io.openremote:openremote-manager.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.openremote:openremote-manager` | Maven | All versions | 1.24.1 |
| `io.openremote:openremote-manager` | Maven | All versions | 1.24.1 |

## How do I fix CVE-2026-49439?

Upgrade io.openremote:openremote-manager to 1.24.1 or later.

## Is CVE-2026-49439 being exploited?

There is no known exploitation of CVE-2026-49439 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49439 and fix it if it is affected.

What it is: CVE-2026-49439 is a medium-severity missing authorization vulnerability in openremote, published on 11 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49439 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.openremote:openremote-manager (Maven): affected all versions; fixed in 1.24.1
- io.openremote:openremote-manager (Maven): affected all versions; fixed in 1.24.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49439/ (Markdown: https://insights.sbomify.com/CVE-2026-49439/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49439
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49439
- OSV: https://osv.dev/vulnerability/CVE-2026-49439

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49439/
Summaries are generated and may contain mistakes; the official description above is the record.
