# CVE-2026-49442: Cacti: User Enumeration via Error Messages


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-49442, GHSA-m7v2-f3xw-3qh7, UBUNTU-CVE-2026-49442

## What is CVE-2026-49442?

CVE-2026-49442 is a medium-severity vulnerability in cacti, published on 23 Oct 2026. 

### Official description

Cacti is an open source performance and fault management framework. Prior to version 1.2.31, a User Enumeration vulnerability allows an attacker to identify valid usernames on the Cacti service. When a user attempts to log in, the application returns slightly different error messages depending on whether the provided username exists in the system. When username exists on Cacti, in the response, they see Access Denied! Login failed. When it does not exist on Cacti, they see Access Denied! Login Failed. The only difference between the responses is the capitalization of the letter "f" in the word failed. This issue has been patched in version 1.2.31.

Weakness: CWE-204 (Observable Response Discrepancy)

## Which versions are affected by CVE-2026-49442?


## How do I fix CVE-2026-49442?

Upgrade to a fixed version.

## Is CVE-2026-49442 being exploited?

There is no known exploitation of CVE-2026-49442 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49442 and fix it if it is affected.

What it is: CVE-2026-49442 is a medium-severity vulnerability in cacti, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-49442 in the wild and no public exploit code.

Affected product: cacti. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49442/ (Markdown: https://insights.sbomify.com/CVE-2026-49442/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49442
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49442
- OSV: https://osv.dev/vulnerability/CVE-2026-49442

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49442/
Summaries are generated and may contain mistakes; the official description above is the record.
