{"answers":{"affected":"1 open source package ship an affected version, including authentik. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49443 exists.","fix":"Upgrade authentik to a fixed version for your release line: 2025.12.6, 2026.2.4 or 2026.5.1.","what":"CVE-2026-49443 is a high-severity authentication bypass vulnerability in goauthentik authentik, published on 2 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-49443 and fix it if it is affected.\n\nWhat it is: CVE-2026-49443 is a high-severity authentication bypass vulnerability in goauthentik authentik, published on 2 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49443 exists.\n\nAffected packages and fixed versions:\n- authentik (Bitnami): affected all versions; fixed in 2025.12.6, 2026.2.4, 2026.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-49443/ (Markdown: https://insights.sbomify.com/CVE-2026-49443/index.md)","id":"CVE-2026-49443","markdown":"https://insights.sbomify.com/CVE-2026-49443/index.md","name":"CVE-2026-49443","record":{"aliases":["BIT-authentik-2026-49443","GHSA-wr38-7xg8-fqxr"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Identity provider","requires_auth":"low_privilege","summary":"Attackers can modify source connection mappings to log into arbitrary accounts, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"authentik","vendor":"goauthentik"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"authentik is an open-source identity provider. Prior to versions 2025.12.6, 2026.2.4, and 2026.5.1, an attacker with the ability to change a source connection, and an account in one of the configured sources can log into any account. This issue has been patched in versions 2025.12.6, 2026.2.4, and 2026.5.1.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"authentik: `UserSourceConnection.user` and `GroupSourceConnection.group` are changeable through the API","id":"CVE-2026-49443","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"n8n: Python sandbox escape","id":"CVE-2026-49444"},"packages":[{"ecosystem":"Bitnami","fixed":["2025.12.6","2026.2.4","2026.5.1"],"introduced":["0","2026.0.0","2026.3.0"],"last_affected":[],"package":"authentik","purl":"pkg:bitnami/authentik","source":"BIT-authentik-2026-49443"}],"prev":{"headline":"Cacti: User Enumeration via Error Messages","id":"CVE-2026-49442"},"products":["authentik"],"published":"2026-06-02","related":[{"cvss_score":9.8,"headline":"authentik: SourceStage bypass via empty POST","id":"CVE-2026-49448","kev_date_added":null,"published":"2026-06-02"},{"cvss_score":9.7,"headline":"authentik potential installation takeover when default admin user is deleted","id":"CVE-2023-46249","kev_date_added":null,"published":"2023-10-31"},{"cvss_score":9.4,"headline":"authentik vulnerable to Improper Authentication via invitation URL token reuse","id":"CVE-2022-23555","kev_date_added":null,"published":"2022-12-28"},{"cvss_score":9.3,"headline":"authentik: Reflected XSS in SFE AutosubmitStage allows IDP account takeover","id":"CVE-2026-42849","kev_date_added":null,"published":"2026-06-02"},{"cvss_score":9.1,"headline":"authentik affected by Remote Code Execution via Context Key Injection in PropertyMapping Test Endpoint","id":"CVE-2026-25227","kev_date_added":null,"published":"2026-02-12"},{"cvss_score":9.1,"headline":"authentik vulnerable to password authentication bypass via X-Forwarded-For HTTP header","id":"CVE-2024-47070","kev_date_added":null,"published":"2024-09-27"},{"cvss_score":9.1,"headline":"Insufficient user check in FlowTokens by Email stage","id":"CVE-2023-26481","kev_date_added":null,"published":"2023-03-04"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-03","vendors":["goauthentik"]},"summary":"Attackers can modify source connection mappings to log into arbitrary accounts, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2026-49443/"}