CVE-2026-49444 n8n: Python sandbox escape
Authenticated users can escape the Python sandbox in n8n to execute arbitrary code on the task runner container.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-49444?
CVE-2026-49444 is a high-severity code injection vulnerability in N8n N8n, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n is an open source workflow automation platform. Prior to 1.123.48, 2.21.8, and 2.22.4, an authenticated user with permission to create or modify workflows containing a Python Code Node could escape the sandbox and achieve arbitrary code execution on the task runner container. This vulnerability is fixed in 1.123.48, 2.21.8, and 2.22.4.
Weakness: CWE-20
Which versions are affected by CVE-2026-49444?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.48 |
n8n npm | All versions | 1.123.48 |
n8n npm | From 2.0.0-rc.0 | 2.21.8 |
n8n npm | From 2.0.0-rc.0 | 2.21.8 |
n8n npm | From 2.22.0 | 2.22.4 |
n8n npm | From 2.22.0 | 2.22.4 |
Products include N8n N8n.
How do I fix CVE-2026-49444?
Upgrade n8n to a fixed version for your release line: 1.123.48, 2.21.8 or 2.22.4.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-49444 being exploited?
There is no known exploitation of CVE-2026-49444 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-9pq8-m8gp-4p53, MINI-g792-h9mv-pvr9, ROOT-APP-NPM-CVE-2026-49444.