# CVE-2026-49455: Waku: Cross-Origin CSRF on RSC Server Action Dispatch

> Attackers can force victims to execute state-mutating server actions via cross-origin requests due to missing Origin validation in Waku.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Sep 2026
- **Updated:** 3 Sep 2026
- **Also known as:** GHSA-75w3-gmqx-993q

## What is CVE-2026-49455?

CVE-2026-49455 is a medium-severity vulnerability in wakujs waku, published on 3 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Waku is the minimal React framework. Prior to version 1.0.0-beta.1, Waku's RSC request dispatcher invokes server actions without validating the request's Origin (or Sec-Fetch-Site) header. A cross-origin web attacker can therefore cause a victim browser to issue an authenticated POST to a registered server action endpoint using a CORS-safelisted content type (text/plain), which does not trigger a preflight. Any state-mutating server action that the application exposes via 'use server' can be invoked with the victim's cookies attached. This issue has been patched in version 1.0.0-beta.1.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-49455?

2 open source packages ship an affected version, including waku.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `waku` | npm | All versions | 1.0.0-beta.1 |
| `waku` | npm | All versions | 1.0.0-beta.1 |

## How do I fix CVE-2026-49455?

Upgrade waku to 1.0.0-beta.1 or later.

## Is CVE-2026-49455 being exploited?

There is no known exploitation of CVE-2026-49455 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49455 and fix it if it is affected.

What it is: CVE-2026-49455 is a medium-severity vulnerability in wakujs waku, published on 3 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-49455 in the wild and no public exploit code.

Affected packages and fixed versions:
- waku (npm): affected all versions; fixed in 1.0.0-beta.1
- waku (npm): affected all versions; fixed in 1.0.0-beta.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49455/ (Markdown: https://insights.sbomify.com/CVE-2026-49455/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49455
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49455
- OSV: https://osv.dev/vulnerability/CVE-2026-49455

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49455/
Summaries are generated and may contain mistakes; the official description above is the record.
