# CVE-2026-49465: n8n: Git Node Clone and Push Operations Bypass File Sandbox

> Authenticated users can bypass file sandbox restrictions via Git node operations to read local repository contents.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-5xp3-2w67-427v, MINI-6wvf-4fww-7hv3, ROOT-APP-NPM-CVE-2026-49465

## What is CVE-2026-49465?

CVE-2026-49465 is a medium-severity path traversal vulnerability in N8n N8n, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

n8n is an open source workflow automation platform. Prior to 1.123.48, 2.21.8, and 2.22.4, an authenticated user with permission to create or modify workflows could supply a local filesystem path as the source repository in the Git node's Clone operation, or as the target repository in the Push operation, bypassing the N8N_RESTRICT_FILE_ACCESS_TO file sandbox. This allowed the contents of any local git repository accessible to the n8n process to be cloned into an allowed path and read, circumventing the access restrictions that correctly blocked direct file reads to the same paths. This vulnerability is fixed in 1.123.48, 2.21.8, and 2.22.4.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-49465?

6 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 1.123.48 |
| `n8n` | npm | All versions | 1.123.48 |
| `n8n` | npm | From 2.0.0-rc.0 | 2.21.8 |
| `n8n` | npm | From 2.0.0-rc.0 | 2.21.8 |
| `n8n` | npm | From 2.22.0 | 2.22.4 |
| `n8n` | npm | From 2.22.0 | 2.22.4 |

Products: N8n N8n.

## How do I fix CVE-2026-49465?

Upgrade n8n to a fixed version for your release line: 1.123.48, 2.21.8 or 2.22.4.

## Is CVE-2026-49465 being exploited?

There is no known exploitation of CVE-2026-49465 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49465 and fix it if it is affected.

What it is: CVE-2026-49465 is a medium-severity path traversal vulnerability in N8n N8n, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49465 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 1.123.48
- n8n (npm): affected all versions; fixed in 1.123.48
- n8n (npm): affected from 2.0.0-rc.0; fixed in 2.21.8
- n8n (npm): affected from 2.0.0-rc.0; fixed in 2.21.8
- n8n (npm): affected from 2.22.0; fixed in 2.22.4
- n8n (npm): affected from 2.22.0; fixed in 2.22.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49465/ (Markdown: https://insights.sbomify.com/CVE-2026-49465/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49465
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49465
- OSV: https://osv.dev/vulnerability/CVE-2026-49465

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49465/
Summaries are generated and may contain mistakes; the official description above is the record.
