# CVE-2026-49468: LiteLLM: Authentication Bypass via Host Header Injection

> Attackers can bypass authentication on protected management routes by manipulating the Host header, potentially accessing sensitive data.

- **Severity:** Critical 9.5 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CLEANSTART-2026-PO19618, ECHO-472d-a2db-709d, GHSA-4xpc-pv4p-pm3w, MINI-2933-9pph-9xwj, MINI-3hvp-r9fc-rpxp, MINI-447f-xq53-g887, MINI-5c25-v63v-42m8, MINI-gm4v-5jxc-8h7m, MINI-jc65-7rg6-fpm4, PYSEC-2026-388

## What is CVE-2026-49468?

CVE-2026-49468 is a critical authentication bypass vulnerability in BerriAI litellm, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.84.0, a Host-header parsing flaw in the LiteLLM proxy could, under specific conditions, allow unauthenticated access to protected management routes. The auth layer derived the effective route from request.url.path in litellm/proxy/auth/auth_utils.py::get_request_route(), which Starlette reconstructs from the Host header. A crafted Host could therefore make the auth gate evaluate a different route from the one FastAPI dispatched. This vulnerability is fixed in 1.84.0.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2026-49468?

3 open source packages ship an affected version, including litellm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litellm` | PyPI | All versions | 1.84.0 |
| `litellm` | PyPI | All versions | 1.84.0 |
| `litellm` | PyPI | All versions | 1.84.0 |

Products: Litellm Litellm.

## How do I fix CVE-2026-49468?

Upgrade litellm to 1.84.0 or later.

## Is CVE-2026-49468 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49468 exists.

Public exploit code:

- CVE-2026-49468 — LiteLLM (<1.84.0) unauthenticated auth bypass via Host-header route confusion. PoC + docker lab. (github_poc): https://github.com/BiiTts/CVE-2026-49468-LiteLLM-Auth-Bypass
- LiteLLM Proxy < 1.84.0 - Host Header Authentication Bypass (nuclei): http/cves/2026/CVE-2026-49468.yaml

## Other vulnerabilities in BerriAI litellm

- [CVE-2026-42208](https://insights.sbomify.com/CVE-2026-42208/): BerriAI LiteLLM SQL Injection (critical 9.3, exploited in the wild)
- [CVE-2026-59822](https://insights.sbomify.com/CVE-2026-59822/): BerriAI LiteLLM Improper Authentication (high 8.8, exploited in the wild)
- [CVE-2026-42271](https://insights.sbomify.com/CVE-2026-42271/): BerriAI LiteLLM Command Injection (high 8.7, exploited in the wild)
- [CVE-2024-5751](https://insights.sbomify.com/CVE-2024-5751/): Remote Code Execution in BerriAI/litellm (critical 9.8)
- [CVE-2024-2952](https://insights.sbomify.com/CVE-2024-2952/): Server-Side Template Injection in BerriAI/litellm (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49468 and fix it if it is affected.

What it is: CVE-2026-49468 is a critical authentication bypass vulnerability in BerriAI litellm, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49468 exists.

Affected packages and fixed versions:
- litellm (PyPI): affected all versions; fixed in 1.84.0
- litellm (PyPI): affected all versions; fixed in 1.84.0
- litellm (PyPI): affected all versions; fixed in 1.84.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49468/ (Markdown: https://insights.sbomify.com/CVE-2026-49468/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49468
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49468
- OSV: https://osv.dev/vulnerability/CVE-2026-49468

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49468/
Summaries are generated and may contain mistakes; the official description above is the record.
