# CVE-2026-49473: @cedar-policy/authorization-for-expressjs has an authorization bypass via query string manipulation

> Attackers can bypass authorization checks by manipulating query strings, gaining unauthorized access to restricted endpoints in Express applications using this middleware.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** GHSA-g4w6-vmgf-xqvx

## What is CVE-2026-49473?

CVE-2026-49473 is a high-severity authentication bypass vulnerability in cedar-policy authorization-for-expressjs, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

@cedar-policy/authorization-for-expressjs is an open-source Express.js middleware that integrates Cedar authorization into Express applications by mapping HTTP requests to Cedar actions and evaluating authorization policies before allowing requests to proceed. Versions prior to 0.3.0 have an issue where, under certain circumstances, the middleware matches incoming requests against Cedar action mappings using req.originalUrl, which includes the query string, while Express routes requests using only the path component. The middleware uses req.originalUrl to match incoming requests against Cedar action mappings. In Express, req.originalUrl includes the query string, while route matching uses only the path. This creates a divergence between what Cedar authorizes and what Express executes. When an application defines separate actions for overlapping path prefixes with different authorization requirements (for example, GET /users for listing all users with admin-only access, and GET /users/{id} for retrieving a single user with any authenticated user access), an actor can append a query string to bypass the more restrictive policy. Sending GET /users/?x=1 causes the middleware to match against /users/{id} (with id parameter set to ?x=1) and evaluate the less restrictive action, while Express routes the request to the /users list handler. This allows inappropriate access to the more restrictive endpoint. This issue has been addressed in version 0.30. Some workarounds are available. Validate and sanitize incoming request paths before they reach the authorization middleware. Ensure that applications do not rely solely on the middleware for authorization when defining multiple actions on overlapping path prefixes with different permission levels.

Weakness: CWE-863 (Incorrect Authorization), CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2026-49473?

2 open source packages ship an affected version, including @cedar-policy/authorization-for-expressjs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@cedar-policy/authorization-for-expressjs` | npm | All versions | 0.3.0 |
| `@cedar-policy/authorization-for-expressjs` | npm | All versions | 0.3.0 |

## How do I fix CVE-2026-49473?

Upgrade @cedar-policy/authorization-for-expressjs to 0.3.0 or later.

## Is CVE-2026-49473 being exploited?

There is no known exploitation of CVE-2026-49473 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49473 and fix it if it is affected.

What it is: CVE-2026-49473 is a high-severity authentication bypass vulnerability in cedar-policy authorization-for-expressjs, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49473 in the wild and no public exploit code.

Affected packages and fixed versions:
- @cedar-policy/authorization-for-expressjs (npm): affected all versions; fixed in 0.3.0
- @cedar-policy/authorization-for-expressjs (npm): affected all versions; fixed in 0.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49473/ (Markdown: https://insights.sbomify.com/CVE-2026-49473/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49473
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49473
- OSV: https://osv.dev/vulnerability/CVE-2026-49473

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49473/
Summaries are generated and may contain mistakes; the official description above is the record.
