# CVE-2026-49483: Code for IBMi: Uses IBM i components with blind check allowing arbitrary code execution

> A local attacker can modify IBM i components to execute arbitrary code under the connecting user's account due to insufficient integrity checks.

- **Severity:** High 8.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 12 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-rmqv-7c5v-wvjc

## What is CVE-2026-49483?

CVE-2026-49483 is a high-severity vulnerability in codefori vscode-ibmi, published on 12 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Code for IBMi is a Visual Studio Code extension for maintaining and compiling ILE languages on the IBMi platform. Prior to 3.0.1, IBMi components implementing IBMiComponent were accepted after checking that a procedure existed without reliably verifying component integrity. Components installed with broad public permissions allow another local account to alter a program such as GETMBRINFO. A later connection can execute the altered program under the connecting account because the LONG_COMMENT marker alone does not establish integrity. This issue is fixed in version 3.0.1.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource), CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-49483?


## How do I fix CVE-2026-49483?

No fix has been published for CVE-2026-49483 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-49483 being exploited?

There is no known exploitation of CVE-2026-49483 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49483 and fix it if it is affected.

What it is: CVE-2026-49483 is a high-severity vulnerability in codefori vscode-ibmi, published on 12 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-49483 in the wild and no public exploit code.

Affected product: codefori vscode-ibmi. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49483/ (Markdown: https://insights.sbomify.com/CVE-2026-49483/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49483
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49483
- OSV: https://osv.dev/vulnerability/CVE-2026-49483

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49483/
Summaries are generated and may contain mistakes; the official description above is the record.
