# CVE-2026-49487: Apache Airflow: Task-instance API exposes secrets in deferred trigger kwargs

> Authenticated users with DAG read access can view secrets in deferred task trigger kwargs via the REST API.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2026
- **Updated:** 16 Sep 2026
- **Also known as:** BIT-airflow-2026-49487, CLEANSTART-2026-SQ68931, ECHO-deab-be92-4482, GHSA-22hf-vx2v-gjff, MINI-rgv4-xp29-xqpw, MINI-xxcg-68ph-7ghx, PYSEC-2026-2088

## What is CVE-2026-49487?

CVE-2026-49487 is a medium-severity vulnerability in Apache Airflow, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Apache Airflow before 3.3.0, the REST API task-instance detail and list
endpoints returned a deferred task's trigger kwargs without masking. When a
deferred operator passed a secret (for example a provider API key) into its
trigger, any authenticated user with DAG-scoped task-instance read access for
that DAG could read that secret in clear text while the task was deferred.
Users should upgrade to apache-airflow 3.3.0 or later, which masks sensitive
values in trigger kwargs returned by the API.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-49487?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 3.3.0 |
| `apache-airflow` | PyPI | All versions | 3.3.0 |
| `apache-airflow` | PyPI | All versions | 3.3.0 |
| `airflow` | Bitnami | All versions | 3.3.0 |

Products: Apache Airflow.

## How do I fix CVE-2026-49487?

Upgrade apache-airflow to 3.3.0 or later.

## Is CVE-2026-49487 being exploited?

There is no known exploitation of CVE-2026-49487 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49487 and fix it if it is affected.

What it is: CVE-2026-49487 is a medium-severity vulnerability in Apache Airflow, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49487 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 3.3.0
- apache-airflow (PyPI): affected all versions; fixed in 3.3.0
- apache-airflow (PyPI): affected all versions; fixed in 3.3.0
- airflow (Bitnami): affected all versions; fixed in 3.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49487/ (Markdown: https://insights.sbomify.com/CVE-2026-49487/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49487
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49487
- OSV: https://osv.dev/vulnerability/CVE-2026-49487

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49487/
Summaries are generated and may contain mistakes; the official description above is the record.
