CVE-2026-49488 Apache OpenMeetings: Arbitrary File Read

Medium 6.5 Published Updated

A moderator can read arbitrary files on the server via path traversal, exposing sensitive data like credentials.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-49488?

CVE-2026-49488 is a medium-severity path traversal vulnerability in Apache OpenMeetings, published on 14 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache OpenMeetings.

This issue affects Apache OpenMeetings: from 5.0.0 before 9.1.0. An attacker with moderator rights in any room can read arbitrary files accessible to the OS account running the OM server, including credentials and secrets, via a crafted download request.

Users are recommended to upgrade to version 9.1.0, which fixes the issue.

Weakness: CWE-22

Which versions are affected by CVE-2026-49488?

It affects 1 product.

Products include Apache Openmeetings.

How do I fix CVE-2026-49488?

No fix has been published for CVE-2026-49488 yet. Limit exposure of the affected software until one is available.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2026-49488 being exploited?

There is no known exploitation of CVE-2026-49488 in the wild and no public exploit code.

Sources

Also known as GHSA-436m-m73c-vq4g.

Is CVE-2026-49488 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free