CVE-2026-49757 OAuth2/OIDC account takeover in AshAuthentication via email-based user matching
Attackers can take over local user accounts by registering with a victim's email on an OAuth provider, bypassing proper identity verification.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-49757?
CVE-2026-49757 is a critical authentication bypass vulnerability in team-alembic ash_authentication, published on 15 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Authentication Bypass by Spoofing vulnerability in team-alembic AshAuthentication allows account takeover of local users via OAuth2/OIDC sign-in.
AshAuthentication's OAuth2 and OIDC family strategies matched the local user by email address (an upsert on the email field, or a user-defined sign-in filter) rather than by the OpenID Connect iss/sub claim combination. Per OpenID Connect Core §5.7, only iss/sub uniquely and stably identifies an end-user; other claims, including email, MUST NOT be used as unique identifiers.
A provider login presenting a victim's email, including an unverified email, a reused email, or an account with email_verified: false, resolved to and signed in as the victim's existing local account. An unauthenticated attacker who can register an account on any accepted OAuth provider with the victim's email (or who benefits from provider-side email reuse or reclamation) obtains the victim's full local privileges.
The fix resolves users by the (strategy, sub) identity stored in a user identity resource, and only links a new sub to an existing local account by email when the provider's email_verified claim is trusted (trust_email_verified?).
This issue affects ash_authentication from 0.1.0 before 4.14.0 and from 5.0.0-rc.0 before 5.0.0-rc.10.
Weakness: CWE-290
Which versions are affected by CVE-2026-49757?
5 open source packages ship an affected version, including ash_authentication.
| Package | Affected | Fixed in |
|---|---|---|
ash_authentication Hex | From 0.1.0 | 4.14.0, 5.0.0-rc.10 |
ash_authentication Hex | From 0.1.0 | 4.14.0 |
ash_authentication Hex | From 0.1.0 | 4.14.0 |
ash_authentication Hex | From 5.0.0-rc.0 | 5.0.0-rc.10 |
ash_authentication Hex | From 5.0.0-rc.0 | 5.0.0-rc.10 |
How do I fix CVE-2026-49757?
Upgrade ash_authentication to a fixed version for your release line: 4.14.0 or 5.0.0-rc.10.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-49757 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49757 exists.
Public exploit code: 1 proofs of concept on GitHub.
Sources
Also known as CVE-2026-55616, EEF-CVE-2026-49757, GHSA-777c-2fxx-qr28.