{"answers":{"affected":"6 open source packages ship an affected version, including org.dspace:dspace-api.","exploited":"There is no known exploitation of CVE-2026-49832 in the wild and no public exploit code.","fix":"Upgrade org.dspace:dspace-api to a fixed version for your release line: 10.0, 8.4 or 9.3.","what":"CVE-2026-49832 is a high-severity code injection vulnerability in DSpace, published on 2 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-49832 and fix it if it is affected.\n\nWhat it is: CVE-2026-49832 is a high-severity code injection vulnerability in DSpace, published on 2 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-49832 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.dspace:dspace-api (Maven): affected from 10.0-rc1; fixed in 10.0\n- org.dspace:dspace-api (Maven): affected from 10.0-rc1; fixed in 10.0\n- org.dspace:dspace-api (Maven): affected from 8.0-rc1; fixed in 8.4\n- org.dspace:dspace-api (Maven): affected from 8.0-rc1; fixed in 8.4\n- org.dspace:dspace-api (Maven): affected from 9.0-rc1; fixed in 9.3\n- org.dspace:dspace-api (Maven): affected from 9.0-rc1; fixed in 9.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-49832/ (Markdown: https://insights.sbomify.com/CVE-2026-49832/index.md)","id":"CVE-2026-49832","markdown":"https://insights.sbomify.com/CVE-2026-49832/index.md","name":"CVE-2026-49832","record":{"aliases":["GHSA-9x82-rm84-c6x7"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"DSpace repository application","requires_auth":"high_privilege","summary":"Attackers can execute arbitrary code via Velocity templates in DSpace's LDN messaging system, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"DSpace open source software is a repository application which provides durable access to digital resources. From versions 8.0-rc1 to before 8.4, versions 9.0-rc1 to before 9.3, and version 10-rc1, Remote Code Execution (RCE) is possible via Velocity Templates used by DSpace for COAR Notify/LDN messages. This issue has been patched in versions 8.4, 9.3, and 10.0.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"DSpace: Remote Code Execution (RCE) possible in Velocity Templates used by LDN","id":"CVE-2026-49832","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":6,"n_references":3,"next":{"headline":"DSpace: Path Traversal possible in LDN message generation","id":"CVE-2026-49833"},"packages":[{"ecosystem":"Maven","fixed":["10.0"],"introduced":["10.0-rc1"],"last_affected":[],"package":"org.dspace:dspace-api","purl":null,"source":"GHSA-9x82-rm84-c6x7"},{"ecosystem":"Maven","fixed":["10.0"],"introduced":["10.0-rc1"],"last_affected":[],"package":"org.dspace:dspace-api","purl":"pkg:maven/org.dspace/dspace-api","source":"GHSA-9x82-rm84-c6x7"},{"ecosystem":"Maven","fixed":["8.4"],"introduced":["8.0-rc1"],"last_affected":[],"package":"org.dspace:dspace-api","purl":null,"source":"GHSA-9x82-rm84-c6x7"},{"ecosystem":"Maven","fixed":["8.4"],"introduced":["8.0-rc1"],"last_affected":[],"package":"org.dspace:dspace-api","purl":"pkg:maven/org.dspace/dspace-api","source":"GHSA-9x82-rm84-c6x7"},{"ecosystem":"Maven","fixed":["9.3"],"introduced":["9.0-rc1"],"last_affected":[],"package":"org.dspace:dspace-api","purl":null,"source":"GHSA-9x82-rm84-c6x7"},{"ecosystem":"Maven","fixed":["9.3"],"introduced":["9.0-rc1"],"last_affected":[],"package":"org.dspace:dspace-api","purl":"pkg:maven/org.dspace/dspace-api","source":"GHSA-9x82-rm84-c6x7"}],"prev":{"headline":"DSpace: Curation Task Reporter output path is not restricted to trusted directories (Path Traversal Vulnerability)","id":"CVE-2026-49831"},"products":["DSpace"],"published":"2026-09-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-02","vendors":["DSpace"]},"summary":"Attackers can execute arbitrary code via Velocity templates in DSpace's LDN messaging system, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2026-49832/"}