CVE-2026-49833 DSpace: Path Traversal possible in LDN message generation
An authenticated DSpace administrator can exploit path traversal in LDN message generation to read arbitrary files and potentially execute code via template injection.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-49833?
CVE-2026-49833 is a medium-severity path traversal vulnerability in DSpace, published on 2 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
DSpace open source software is a repository application which provides durable access to digital resources. From versions 8.0-rc1 to before 8.4, 9.0-rc1 to before 9.3, and 10-rc1 to before 10.0, a path traversal vulnerability is possible via the COAR Notify / LDN service in DSpace. The attacker MUST already have DSpace administrator credentials in order to perform the attack. When reading a file input stream of an "inbound pattern" / "template", used to generate an LDN message, the LDN class does not check for path traversal or restrict the templates to a known base path. This could allow an untrusted file from elsewhere in the file system (e.g. an export log, a bitstream path, a temporary file) to be read and interpreted as an Apache Velocity template. This issue has been patched in versions 8.4, 9.3, and 10.0.
Weakness: CWE-22
Which versions are affected by CVE-2026-49833?
6 open source packages ship an affected version, including org.dspace:dspace-api.
| Package | Affected | Fixed in |
|---|---|---|
org.dspace:dspace-api Maven | From 10.0-rc1 | 10.0 |
org.dspace:dspace-api Maven | From 10.0-rc1 | 10.0 |
org.dspace:dspace-api Maven | From 8.0-rc1 | 8.4 |
org.dspace:dspace-api Maven | From 8.0-rc1 | 8.4 |
org.dspace:dspace-api Maven | From 9.0-rc1 | 9.3 |
org.dspace:dspace-api Maven | From 9.0-rc1 | 9.3 |
How do I fix CVE-2026-49833?
Upgrade org.dspace:dspace-api to a fixed version for your release line: 10.0, 8.4 or 9.3.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2026-49833 being exploited?
There is no known exploitation of CVE-2026-49833 in the wild and no public exploit code.
Sources
Also known as GHSA-9qm4-rh6w-pq5x.