{"answers":{"affected":"2 open source packages ship an affected version, including wetty.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49864 exists.","fix":"Upgrade wetty to 3.0.4 or later.","what":"CVE-2026-49864 is a high-severity cross-site scripting vulnerability in butlerx wetty, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-49864 and fix it if it is affected.\n\nWhat it is: CVE-2026-49864 is a high-severity cross-site scripting vulnerability in butlerx wetty, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49864 exists.\n\nAffected packages and fixed versions:\n- wetty (npm): affected all versions; fixed in 3.0.4\n- wetty (npm): affected all versions; fixed in 3.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-49864/ (Markdown: https://insights.sbomify.com/CVE-2026-49864/index.md)","id":"CVE-2026-49864","markdown":"https://insights.sbomify.com/CVE-2026-49864/index.md","name":"CVE-2026-49864","record":{"aliases":["GHSA-p26j-h7wj-r568"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Web terminal client","requires_auth":"none","summary":"Attacker can execute arbitrary JavaScript and inject keystrokes into victim's SSH session via malicious file download filenames in wetty.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"wetty provides terminal access in browser over http/https. Prior to version 3.0.4, the wetty client decodes a base64 filename from the file-download escape sequence and interpolates it raw into a Toastify HTML string (`escapeMarkup: false`). Any output the victim renders - a `cat`'d file, a tailed log, an SSH MOTD, a `curl` response - that contains `\\x1b[5i...:...\\x1b[4i` runs script in the wetty origin and types attacker-chosen keystrokes into the victim's SSH session. Version 3.0.4 fixes the issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"wetty vulnerable to DOM XSS via file-download filename","id":"CVE-2026-49864","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Kimai has Server-Side Request Forgery in Invoice PDF Rendering via Markdown Image URLs","id":"CVE-2026-49865"},"packages":[{"ecosystem":"npm","fixed":["3.0.4"],"introduced":["0"],"last_affected":[],"package":"wetty","purl":null,"source":"GHSA-p26j-h7wj-r568"},{"ecosystem":"npm","fixed":["3.0.4"],"introduced":["0"],"last_affected":[],"package":"wetty","purl":"pkg:npm/wetty","source":"GHSA-p26j-h7wj-r568"}],"prev":{"headline":"Deno: WebSocket API sandbox bypass via missing post-DNS check","id":"CVE-2026-49860"},"products":["wetty"],"published":"2026-08-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-18","vendors":["butlerx"]},"summary":"Attacker can execute arbitrary JavaScript and inject keystrokes into victim's SSH session via malicious file download filenames in wetty.","url":"https://insights.sbomify.com/CVE-2026-49864/"}