# CVE-2026-49864: wetty vulnerable to DOM XSS via file-download filename

> Attacker can execute arbitrary JavaScript and inject keystrokes into victim's SSH session via malicious file download filenames in wetty.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-p26j-h7wj-r568

## What is CVE-2026-49864?

CVE-2026-49864 is a high-severity cross-site scripting vulnerability in butlerx wetty, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

wetty provides terminal access in browser over http/https. Prior to version 3.0.4, the wetty client decodes a base64 filename from the file-download escape sequence and interpolates it raw into a Toastify HTML string (`escapeMarkup: false`). Any output the victim renders - a `cat`'d file, a tailed log, an SSH MOTD, a `curl` response - that contains `\x1b[5i...:...\x1b[4i` runs script in the wetty origin and types attacker-chosen keystrokes into the victim's SSH session. Version 3.0.4 fixes the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-49864?

2 open source packages ship an affected version, including wetty.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wetty` | npm | All versions | 3.0.4 |
| `wetty` | npm | All versions | 3.0.4 |

## How do I fix CVE-2026-49864?

Upgrade wetty to 3.0.4 or later.

## Is CVE-2026-49864 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49864 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49864 and fix it if it is affected.

What it is: CVE-2026-49864 is a high-severity cross-site scripting vulnerability in butlerx wetty, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49864 exists.

Affected packages and fixed versions:
- wetty (npm): affected all versions; fixed in 3.0.4
- wetty (npm): affected all versions; fixed in 3.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49864/ (Markdown: https://insights.sbomify.com/CVE-2026-49864/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49864
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49864
- OSV: https://osv.dev/vulnerability/CVE-2026-49864

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49864/
Summaries are generated and may contain mistakes; the official description above is the record.
