# CVE-2026-49865: Kimai has Server-Side Request Forgery in Invoice PDF Rendering via Markdown Image URLs

> Attackers can force the Kimai server to make arbitrary HTTP requests via Markdown image URLs in invoice PDFs, enabling internal network probing.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-pj8j-p4g4-4vw8

## What is CVE-2026-49865?

CVE-2026-49865 is a medium-severity server-side request forgery vulnerability in kimai, published on 11 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kimai is an open-source time tracking application. Versions prior to 2.58.0 contain a server-side request forgery vulnerability in their invoice PDF preview and generation workflow. If an attacker can control Markdown content that is later rendered into an invoice PDF, such as `Customer.invoiceText`, the server-side PDF renderer will fetch remote image URLs embedded in Markdown image syntax. This allows the application server to issue outbound requests to attacker-controlled or internal targets during PDF rendering. The behavior can be used for internal network probing, server-side reachability checks, and potentially follow-on exploitation depending on deployment environment and accessible internal services. Version 2.58.0 patches the issue.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-49865?

2 open source packages ship an affected version, including kimai/kimai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kimai/kimai` | Packagist | All versions | 2.58.0 |
| `kimai/kimai` | Packagist | All versions | 2.58.0 |

## How do I fix CVE-2026-49865?

Upgrade kimai/kimai to 2.58.0 or later.

## Is CVE-2026-49865 being exploited?

There is no known exploitation of CVE-2026-49865 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49865 and fix it if it is affected.

What it is: CVE-2026-49865 is a medium-severity server-side request forgery vulnerability in kimai, published on 11 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49865 in the wild and no public exploit code.

Affected packages and fixed versions:
- kimai/kimai (Packagist): affected all versions; fixed in 2.58.0
- kimai/kimai (Packagist): affected all versions; fixed in 2.58.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49865/ (Markdown: https://insights.sbomify.com/CVE-2026-49865/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49865
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49865
- OSV: https://osv.dev/vulnerability/CVE-2026-49865

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49865/
Summaries are generated and may contain mistakes; the official description above is the record.
