{"answers":{"affected":"2 open source packages ship an affected version, including @libp2p/gossipsub.","exploited":"There is no known exploitation of CVE-2026-49866 in the wild and no public exploit code.","fix":"Upgrade @libp2p/gossipsub to 16.0.0 or later.","what":"CVE-2026-49866 is a high-severity denial of service vulnerability in js-libp2p, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-49866 and fix it if it is affected.\n\nWhat it is: CVE-2026-49866 is a high-severity denial of service vulnerability in js-libp2p, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-49866 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @libp2p/gossipsub (npm): affected all versions; fixed in 16.0.0\n- @libp2p/gossipsub (npm): affected all versions; fixed in 16.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-49866/ (Markdown: https://insights.sbomify.com/CVE-2026-49866/index.md)","id":"CVE-2026-49866","markdown":"https://insights.sbomify.com/CVE-2026-49866/index.md","name":"CVE-2026-49866","record":{"aliases":["GHSA-cwc9-cp4j-mcvv"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript networking library","requires_auth":"none","summary":"Attackers can cause CPU exhaustion and block the Node.js event loop by sending oversized gossipsub control messages, requiring an upgrade to libp2p.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"libp2p is a JavaScript Implementation of libp2p networking stack. Prior to 16.0.0, @libp2p/gossipsub defaultDecodeRpcLimits set maxIhaveMessageIDs and maxIwantMessageIDs to Infinity, allowing oversized IHAVE and IWANT control message arrays in message/decodeRpc.ts and gossipsub.ts to synchronously iterate roughly 180,000 message IDs per 4 MB frame and block the Node.js event loop. This issue is fixed in version 16.0.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"libp2p: CPU DoS via oversized IHAVE and IWANT control message arrays","id":"CVE-2026-49866","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"DataEase: Authenticated Stored XSS in DataEase Template Static Resources","id":"CVE-2026-49867"},"packages":[{"ecosystem":"npm","fixed":["16.0.0"],"introduced":["0"],"last_affected":[],"package":"@libp2p/gossipsub","purl":null,"source":"GHSA-cwc9-cp4j-mcvv"},{"ecosystem":"npm","fixed":["16.0.0"],"introduced":["0"],"last_affected":[],"package":"@libp2p/gossipsub","purl":"pkg:npm/%40libp2p/gossipsub","source":"GHSA-cwc9-cp4j-mcvv"}],"prev":{"headline":"Kimai has Server-Side Request Forgery in Invoice PDF Rendering via Markdown Image URLs","id":"CVE-2026-49865"},"products":["js-libp2p"],"published":"2026-07-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-09","vendors":["libp2p"]},"summary":"Attackers can cause CPU exhaustion and block the Node.js event loop by sending oversized gossipsub control messages, requiring an upgrade to libp2p.","url":"https://insights.sbomify.com/CVE-2026-49866/"}