# CVE-2026-49866: libp2p: CPU DoS via oversized IHAVE and IWANT control message arrays

> Attackers can cause CPU exhaustion and block the Node.js event loop by sending oversized gossipsub control messages, requiring an upgrade to libp2p.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-cwc9-cp4j-mcvv

## What is CVE-2026-49866?

CVE-2026-49866 is a high-severity denial of service vulnerability in js-libp2p, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

libp2p is a JavaScript Implementation of libp2p networking stack. Prior to 16.0.0, @libp2p/gossipsub defaultDecodeRpcLimits set maxIhaveMessageIDs and maxIwantMessageIDs to Infinity, allowing oversized IHAVE and IWANT control message arrays in message/decodeRpc.ts and gossipsub.ts to synchronously iterate roughly 180,000 message IDs per 4 MB frame and block the Node.js event loop. This issue is fixed in version 16.0.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-49866?

2 open source packages ship an affected version, including @libp2p/gossipsub.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@libp2p/gossipsub` | npm | All versions | 16.0.0 |
| `@libp2p/gossipsub` | npm | All versions | 16.0.0 |

## How do I fix CVE-2026-49866?

Upgrade @libp2p/gossipsub to 16.0.0 or later.

## Is CVE-2026-49866 being exploited?

There is no known exploitation of CVE-2026-49866 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49866 and fix it if it is affected.

What it is: CVE-2026-49866 is a high-severity denial of service vulnerability in js-libp2p, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49866 in the wild and no public exploit code.

Affected packages and fixed versions:
- @libp2p/gossipsub (npm): affected all versions; fixed in 16.0.0
- @libp2p/gossipsub (npm): affected all versions; fixed in 16.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49866/ (Markdown: https://insights.sbomify.com/CVE-2026-49866/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49866
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49866
- OSV: https://osv.dev/vulnerability/CVE-2026-49866

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49866/
Summaries are generated and may contain mistakes; the official description above is the record.
