# CVE-2026-49867: DataEase: Authenticated Stored XSS in DataEase Template Static Resources

> Authenticated attackers can inject malicious SVG scripts into DataEase templates, leading to stored XSS and potential account takeover when victims view the resources.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 15 Jul 2026
- **Updated:** 18 Jul 2026
- **Also known as:** GHSA-jqxj-h53x-mpvf

## What is CVE-2026-49867?

CVE-2026-49867 is a medium-severity cross-site scripting vulnerability in dataease, published on 15 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

DataEase is an open source data visualization and analysis tool. Prior to 2.10.23, DataEase template static resources let authenticated users submit TemplateManageRequest.staticResource through POST /de2api/templateManage/save or DataVisualizationServer.decompression, after which StaticResourceServer.saveFilesToServe and StaticResourceServer.saveSingleFileToServe write Base64-decoded .svg content to /de2api/static-resource/<name>.svg without validating extension, MIME type, decoded bytes, or SVG scriptability, causing stored same-origin cross-site scripting when a victim loads the resource. This issue is fixed in version 2.10.23.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-49867?


## How do I fix CVE-2026-49867?

No fix has been published for CVE-2026-49867 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-49867 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49867 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49867 and fix it if it is affected.

What it is: CVE-2026-49867 is a medium-severity cross-site scripting vulnerability in dataease, published on 15 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49867 exists.

Affected product: dataease. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49867/ (Markdown: https://insights.sbomify.com/CVE-2026-49867/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49867
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49867
- OSV: https://osv.dev/vulnerability/CVE-2026-49867

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49867/
Summaries are generated and may contain mistakes; the official description above is the record.
