CVE-2026-49870 Snipe-IT: TOTP Brute-Forceable Due to Missing Rate Limiting on `POST /two-factor`
Attackers can bypass two-factor authentication via brute-force or profile changes, leading to account takeover in Snipe-IT.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-49870?
CVE-2026-49870 is a medium-severity vulnerability in Snipeitapp Snipe-It, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Snipe-IT is an IT asset/license management system. Prior to 8.6.1, POST /two-factor has no rate limiting, lockout, or attempt counter, allowing an attacker with valid credentials to submit unlimited TOTP guesses against the three accepted codes created by config/google2fa.php window=1. A successful guess creates a fully authenticated session. When two_factor_enabled is 1, POST /account/profile with two_factor_optin=0 can disable two-factor authentication without OTP reverification, while required mode 2 prevents that opt-out. An administrator can also use POST /api/v1/users/two_factor_reset to clear another user's secret. This issue is fixed in version 8.6.1.
Weakness: CWE-770
Which versions are affected by CVE-2026-49870?
2 open source packages ship an affected version, including snipe/snipe-it. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
snipe/snipe-it Packagist | All versions | 8.6.0 |
snipe/snipe-it Packagist | All versions | 8.6.0 |
Products include Snipeitapp Snipe-It.
How do I fix CVE-2026-49870?
Upgrade snipe/snipe-it to 8.6.0 or later.
Is CVE-2026-49870 being exploited?
There is no known exploitation of CVE-2026-49870 in the wild and no public exploit code.
Other vulnerabilities in Snipeitapp Snipe-It
- CVE-2025-63601 File upload in n/a
- CVE-2026-37709 Snipe-IT has insecure permissions in file uploads
- CVE-2026-86738 Snipe-IT before 8.7.0 CSS Injection via Custom CSS
- CVE-2026-116199 Snipe-IT before 8.6.3 Authentication Bypass via Google SSO Callback
- CVE-2022-1380 Stored Cross Site Scripting vulnerability in Item name parameter in snipe/snipe-it
Sources
Also known as GHSA-mr8g-2mj4-pcq2.