CVE-2026-49871 Apache APISIX: cas-auth login CSRF / session injection issue

Low 2.1 Published Updated

A CSRF vulnerability in the cas-auth plugin allows attackers to force victims to authenticate as a different identity, attributing victim actions to the attacker.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-49871?

CVE-2026-49871 is a low-severity vulnerability in Apache APISIX, published on 19 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Cross-Site Request Forgery (CSRF) vulnerability in the cas-auth plugin under default configurations.

This defect allows a remote attacker that manages to send a victim to a webpage controlled by them can cause the victim's browser to become authenticated as a different identity.

Actions the victim takes upstream are then attributed to attackers identity.

This issue affects Apache APISIX: from 3.0.0 through 3.16.0.

Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Weakness: CWE-352

Which versions are affected by CVE-2026-49871?

1 open source package ship an affected version, including apisix. It affects 1 product.

PackageAffectedFixed in
apisix BitnamiFrom 3.0.03.17.0

Products include Apache Apisix.

How do I fix CVE-2026-49871?

Upgrade apisix to 3.17.0 or later.

Is CVE-2026-49871 being exploited?

There is no known exploitation of CVE-2026-49871 in the wild and no public exploit code.

Sources

Also known as BIT-apisix-2026-49871, GHSA-rrqp-g94p-gmh7, MINI-p3gh-hqrr-wr8w.

Is CVE-2026-49871 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free