{"answers":{"affected":"1 open source package ship an affected version, including apisix. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-49871 in the wild and no public exploit code.","fix":"Upgrade apisix to 3.17.0 or later.","what":"CVE-2026-49871 is a low-severity vulnerability in Apache APISIX, published on 19 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-49871 and fix it if it is affected.\n\nWhat it is: CVE-2026-49871 is a low-severity vulnerability in Apache APISIX, published on 19 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-49871 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apisix (Bitnami): affected from 3.0.0; fixed in 3.17.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-49871/ (Markdown: https://insights.sbomify.com/CVE-2026-49871/index.md)","id":"CVE-2026-49871","markdown":"https://insights.sbomify.com/CVE-2026-49871/index.md","name":"CVE-2026-49871","record":{"aliases":["BIT-apisix-2026-49871","GHSA-rrqp-g94p-gmh7","MINI-p3gh-hqrr-wr8w"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"API Gateway","requires_auth":"none","summary":"A CSRF vulnerability in the cas-auth plugin allows attackers to force victims to authenticate as a different identity, attributing victim actions to the attacker.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"apisix","vendor":"apache"}],"cvss":{"score":2.1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Cross-Site Request Forgery (CSRF) vulnerability in the cas-auth plugin under default configurations.\n\nThis defect allows a remote attacker that manages to send a victim to a webpage controlled by them can cause the victim's browser to become authenticated as a different identity.\n\nActions the victim takes upstream are then attributed to attackers identity.\n\nThis issue affects Apache APISIX: from 3.0.0 through 3.16.0.\n\nUsers are recommended to upgrade to version 3.17.0, which fixes the issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache APISIX: cas-auth login CSRF / session injection issue","id":"CVE-2026-49871","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"csrf","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Apache APISIX: Improper authentication in cas-auth plugin","id":"CVE-2026-49872"},"packages":[{"ecosystem":"Bitnami","fixed":["3.17.0"],"introduced":["3.0.0"],"last_affected":[],"package":"apisix","purl":"pkg:bitnami/apisix","source":"BIT-apisix-2026-49871"}],"prev":{"headline":"Snipe-IT: TOTP Brute-Forceable Due to Missing Rate Limiting on `POST /two-factor`","id":"CVE-2026-49870"},"products":["Apache APISIX"],"published":"2026-06-19","related":[{"cvss_score":9.8,"headline":"Apache APISIX Authentication Bypass","id":"CVE-2022-24112","kev_date_added":"2022-08-25","published":"2022-02-11"},{"cvss_score":9.8,"headline":"Apache APISIX: the body_schema check in request-validation plugin can be bypassed","id":"CVE-2022-25757","kev_date_added":null,"published":"2022-03-28"},{"cvss_score":9.1,"headline":"Apache APISIX: forward auth plugin allows header injection","id":"CVE-2026-31908","kev_date_added":null,"published":"2026-04-14"},{"cvss_score":8.7,"headline":"Apache APISIX: Unauthenticated CPU-exhaustion DoS","id":"CVE-2026-75005","kev_date_added":null,"published":"2026-08-27"},{"cvss_score":7.8,"headline":"Privilege escalation in Apache APISIX Java Plugin Runner","id":"CVE-2025-27446","kev_date_added":null,"published":"2025-07-06"},{"cvss_score":7.5,"headline":"Apache APISIX: Openid-connect `tls_verify` field is disabled by default","id":"CVE-2026-31923","kev_date_added":null,"published":"2026-04-14"},{"cvss_score":7.5,"headline":"Apache APISIX: basic-auth logs plaintext credentials at info level","id":"CVE-2025-62232","kev_date_added":null,"published":"2025-10-31"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-22","vendors":["Apache Software Foundation"]},"summary":"A CSRF vulnerability in the cas-auth plugin allows attackers to force victims to authenticate as a different identity, attributing victim actions to the attacker.","url":"https://insights.sbomify.com/CVE-2026-49871/"}