# CVE-2026-49871: Apache APISIX: cas-auth login CSRF / session injection issue

> A CSRF vulnerability in the cas-auth plugin allows attackers to force victims to authenticate as a different identity, attributing victim actions to the attacker.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** BIT-apisix-2026-49871, GHSA-rrqp-g94p-gmh7, MINI-p3gh-hqrr-wr8w

## What is CVE-2026-49871?

CVE-2026-49871 is a low-severity vulnerability in Apache APISIX, published on 19 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-Site Request Forgery (CSRF) vulnerability in the cas-auth plugin under default configurations.

This defect allows a remote attacker that manages to send a victim to a webpage controlled by them can cause the victim's browser to become authenticated as a different identity.

Actions the victim takes upstream are then attributed to attackers identity.

This issue affects Apache APISIX: from 3.0.0 through 3.16.0.

Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-49871?

1 open source package ship an affected version, including apisix. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apisix` | Bitnami | From 3.0.0 | 3.17.0 |

Products: Apache Apisix.

## How do I fix CVE-2026-49871?

Upgrade apisix to 3.17.0 or later.

## Is CVE-2026-49871 being exploited?

There is no known exploitation of CVE-2026-49871 in the wild and no public exploit code.

## Other vulnerabilities in Apache APISIX

- [CVE-2022-24112](https://insights.sbomify.com/CVE-2022-24112/): Apache APISIX Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2022-25757](https://insights.sbomify.com/CVE-2022-25757/): Apache APISIX: the body_schema check in request-validation plugin can be bypassed (critical 9.8)
- [CVE-2026-31908](https://insights.sbomify.com/CVE-2026-31908/): Apache APISIX: forward auth plugin allows header injection (critical 9.1)
- [CVE-2026-75005](https://insights.sbomify.com/CVE-2026-75005/): Apache APISIX: Unauthenticated CPU-exhaustion DoS (high 8.7)
- [CVE-2025-27446](https://insights.sbomify.com/CVE-2025-27446/): Privilege escalation in Apache APISIX Java Plugin Runner (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49871 and fix it if it is affected.

What it is: CVE-2026-49871 is a low-severity vulnerability in Apache APISIX, published on 19 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-49871 in the wild and no public exploit code.

Affected packages and fixed versions:
- apisix (Bitnami): affected from 3.0.0; fixed in 3.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49871/ (Markdown: https://insights.sbomify.com/CVE-2026-49871/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49871
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49871
- OSV: https://osv.dev/vulnerability/CVE-2026-49871

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49871/
Summaries are generated and may contain mistakes; the official description above is the record.
