CVE-2026-49872 Apache APISIX: Improper authentication in cas-auth plugin

Medium 5.3 Published Updated

Attackers can bypass authentication in Apache APISIX by using credentials from a different source when the cas-auth plugin is enabled.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-49872?

CVE-2026-49872 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 19 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Improper Authentication vulnerability in Apache APISIX.

When the cas-auth plugin is used in a route, an attacker can possibly authenticate itself with credentials from a different source. This issue affects Apache APISIX: from 3.0.0 through 3.16.0.

Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Weakness: CWE-287

Which versions are affected by CVE-2026-49872?

1 open source package ship an affected version, including apisix. It affects 1 product.

PackageAffectedFixed in
apisix BitnamiFrom 3.0.03.17.0

Products include Apache Apisix.

How do I fix CVE-2026-49872?

Upgrade apisix to 3.17.0 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-49872 being exploited?

There is no known exploitation of CVE-2026-49872 in the wild and no public exploit code.

Sources

Also known as BIT-apisix-2026-49872, GHSA-cxx6-444w-8847, MINI-7vrw-qmw8-2rqq.

Is CVE-2026-49872 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free