# CVE-2026-49872: Apache APISIX: Improper authentication in cas-auth plugin

> Attackers can bypass authentication in Apache APISIX by using credentials from a different source when the cas-auth plugin is enabled.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** BIT-apisix-2026-49872, GHSA-cxx6-444w-8847, MINI-7vrw-qmw8-2rqq

## What is CVE-2026-49872?

CVE-2026-49872 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 19 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Authentication vulnerability in Apache APISIX.

When the cas-auth plugin is used in a route, an attacker can possibly authenticate itself with credentials from a different source.
This issue affects Apache APISIX: from 3.0.0 through 3.16.0.

Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-49872?

1 open source package ship an affected version, including apisix. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apisix` | Bitnami | From 3.0.0 | 3.17.0 |

Products: Apache Apisix.

## How do I fix CVE-2026-49872?

Upgrade apisix to 3.17.0 or later.

## Is CVE-2026-49872 being exploited?

There is no known exploitation of CVE-2026-49872 in the wild and no public exploit code.

## Other vulnerabilities in Apache APISIX

- [CVE-2022-24112](https://insights.sbomify.com/CVE-2022-24112/): Apache APISIX Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2022-25757](https://insights.sbomify.com/CVE-2022-25757/): Apache APISIX: the body_schema check in request-validation plugin can be bypassed (critical 9.8)
- [CVE-2026-31908](https://insights.sbomify.com/CVE-2026-31908/): Apache APISIX: forward auth plugin allows header injection (critical 9.1)
- [CVE-2026-75005](https://insights.sbomify.com/CVE-2026-75005/): Apache APISIX: Unauthenticated CPU-exhaustion DoS (high 8.7)
- [CVE-2025-27446](https://insights.sbomify.com/CVE-2025-27446/): Privilege escalation in Apache APISIX Java Plugin Runner (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49872 and fix it if it is affected.

What it is: CVE-2026-49872 is a medium-severity authentication bypass vulnerability in Apache APISIX, published on 19 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49872 in the wild and no public exploit code.

Affected packages and fixed versions:
- apisix (Bitnami): affected from 3.0.0; fixed in 3.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49872/ (Markdown: https://insights.sbomify.com/CVE-2026-49872/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49872
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49872
- OSV: https://osv.dev/vulnerability/CVE-2026-49872

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49872/
Summaries are generated and may contain mistakes; the official description above is the record.
