# CVE-2026-49876: Server-side request forgery in Apache Gravitino

> Authenticated attackers can trigger server-side requests to internal networks or cloud metadata via unvalidated job template URIs in Apache Gravitino.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jul 2026
- **Updated:** 13 Jul 2026
- **Also known as:** GHSA-q28r-579j-9qxq, PYSEC-2026-3442

## What is CVE-2026-49876?

CVE-2026-49876 is a medium-severity server-side request forgery vulnerability in Apache Gravitino, published on 13 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Authenticated SSRF in Gravitino JobManager allows server-side HTTP requests to internal network and cloud metadata endpoints via unvalidated job template URIs. A vulnerability in Apache Gravitino.

This issue affects Apache Gravitino: from 1.0.0 through 1.2.1.

Users are recommended to upgrade to version 1.3.0, which fixes the issue.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-49876?

1 open source package ship an affected version, including apache-gravitino. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-gravitino` | PyPI | From 1.0.0 | 1.3.0 |

Products: Apache Gravitino.

## How do I fix CVE-2026-49876?

Upgrade apache-gravitino to 1.3.0 or later.

## Is CVE-2026-49876 being exploited?

There is no known exploitation of CVE-2026-49876 in the wild and no public exploit code.

## Other vulnerabilities in Apache Gravitino

- [CVE-2026-41041](https://insights.sbomify.com/CVE-2026-41041/): Path traversal in Apache Gravitino (critical 9.1)
- [CVE-2025-53648](https://insights.sbomify.com/CVE-2025-53648/): Apache Gravitino: SQL misconfiguration can access or truncate files (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49876 and fix it if it is affected.

What it is: CVE-2026-49876 is a medium-severity server-side request forgery vulnerability in Apache Gravitino, published on 13 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49876 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-gravitino (PyPI): affected from 1.0.0; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49876/ (Markdown: https://insights.sbomify.com/CVE-2026-49876/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49876
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49876
- OSV: https://osv.dev/vulnerability/CVE-2026-49876

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49876/
Summaries are generated and may contain mistakes; the official description above is the record.
