CVE-2026-49877 Apache ActiveMQ: Authenticated web users retain admin access by default in the Web Console
Authenticated low-privilege users can access admin paths in the Web Console due to improper authorization, allowing privilege escalation.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-49877?
CVE-2026-49877 is a high-severity missing authorization vulnerability in Apache Activemq, published on 30 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Improper Authorization vulnerability in Apache ActiveMQ.
An authenticated low-privilege Web Console user by default can access /admin/* paths in the Web Console. The default Jetty settings incorrectly did not limit those paths to only admins. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7.
Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
Weakness: CWE-285
Which versions are affected by CVE-2026-49877?
1 open source package ship an affected version, including activemq. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
activemq Bitnami | All versions | 5.19.8, 6.2.7 |
Products include Apache Activemq.
How do I fix CVE-2026-49877?
Upgrade activemq to a fixed version for your release line: 5.19.8 or 6.2.7.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-49877 being exploited?
There is no known exploitation of CVE-2026-49877 in the wild and no public exploit code.
Other vulnerabilities in Apache Activemq
Sources
Also known as BIT-activemq-2026-49877, DEBIAN-CVE-2026-49877, GHSA-f892-4h9f-j7g9, MINI-2g65-v8r6-28mm, MINI-4qvh-2p7h-5978, MINI-v3x3-9pxm-9p6c and 2 more.