{"answers":{"affected":"1 open source package ship an affected version, including activemq. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-49877 in the wild and no public exploit code.","fix":"Upgrade activemq to a fixed version for your release line: 5.19.8 or 6.2.7.","what":"CVE-2026-49877 is a high-severity missing authorization vulnerability in Apache Activemq, published on 30 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-49877 and fix it if it is affected.\n\nWhat it is: CVE-2026-49877 is a high-severity missing authorization vulnerability in Apache Activemq, published on 30 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-49877 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- activemq (Bitnami): affected all versions; fixed in 5.19.8, 6.2.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-49877/ (Markdown: https://insights.sbomify.com/CVE-2026-49877/index.md)","id":"CVE-2026-49877","markdown":"https://insights.sbomify.com/CVE-2026-49877/index.md","name":"CVE-2026-49877","record":{"aliases":["BIT-activemq-2026-49877","DEBIAN-CVE-2026-49877","GHSA-f892-4h9f-j7g9","MINI-2g65-v8r6-28mm","MINI-4qvh-2p7h-5978","MINI-v3x3-9pxm-9p6c","MINI-xc84-85gj-frw8","UBUNTU-CVE-2026-49877"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache ActiveMQ","requires_auth":"low_privilege","summary":"Authenticated low-privilege users can access admin paths in the Web Console due to improper authorization, allowing privilege escalation.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"activemq","vendor":"apache"}],"cvss":{"score":8.1,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-285","name":"Improper Authorization"}],"description":"Improper Authorization vulnerability in Apache ActiveMQ.\n\nAn authenticated low-privilege Web Console user by default can access /admin/* paths in the Web Console. The default Jetty settings incorrectly did not limit those paths to only admins.\nThis issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7.\n\nUsers are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache ActiveMQ: Authenticated web users retain admin access by default in the Web Console","id":"CVE-2026-49877","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:activemq","products":["apache:activemq"],"type":"missing_authorization","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Memory corruption in Android","id":"CVE-2026-49878"},"packages":[{"ecosystem":"Bitnami","fixed":["5.19.8","6.2.7"],"introduced":["0","6.0.0"],"last_affected":[],"package":"activemq","purl":"pkg:bitnami/activemq","source":"BIT-activemq-2026-49877"}],"prev":{"headline":"Server-side request forgery in Apache Gravitino","id":"CVE-2026-49876"},"products":["Apache ActiveMQ"],"published":"2026-06-30","related":[{"cvss_score":10,"headline":"Apache ActiveMQ Deserialization of Untrusted Data","id":"CVE-2023-46604","kev_date_added":"2023-11-02","published":"2023-10-27"},{"cvss_score":9.8,"headline":"Apache ActiveMQ Improper Input Validation","id":"CVE-2016-3088","kev_date_added":"2022-02-10","published":"2016-06-01"},{"cvss_score":8.8,"headline":"Apache ActiveMQ Improper Input Validation","id":"CVE-2026-34197","kev_date_added":"2026-04-16","published":"2026-04-07"},{"cvss_score":9.8,"headline":"Remote code execution in Apache ActiveMQ","id":"CVE-2020-11998","kev_date_added":null,"published":"2020-09-10"},{"cvss_score":9.8,"headline":"Command Injection in Xstream","id":"CVE-2013-7285","kev_date_added":null,"published":"2019-05-15"},{"cvss_score":9.8,"headline":"Improper Restriction of XML External Entity Reference in Apache ActiveMQ","id":"CVE-2014-3600","kev_date_added":null,"published":"2017-10-27"},{"cvss_score":9.8,"headline":"Improper Input Validation in Apache ActiveMQ","id":"CVE-2015-5254","kev_date_added":null,"published":"2016-01-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-30","vendors":["Apache Software Foundation"]},"summary":"Authenticated low-privilege users can access admin paths in the Web Console due to improper authorization, allowing privilege escalation.","url":"https://insights.sbomify.com/CVE-2026-49877/"}