# CVE-2026-49877: Apache ActiveMQ: Authenticated web users retain admin access by default in the Web Console

> Authenticated low-privilege users can access admin paths in the Web Console due to improper authorization, allowing privilege escalation.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jun 2026
- **Updated:** 30 Jun 2026
- **Also known as:** BIT-activemq-2026-49877, DEBIAN-CVE-2026-49877, GHSA-f892-4h9f-j7g9, MINI-2g65-v8r6-28mm, MINI-4qvh-2p7h-5978, MINI-v3x3-9pxm-9p6c, MINI-xc84-85gj-frw8, UBUNTU-CVE-2026-49877

## What is CVE-2026-49877?

CVE-2026-49877 is a high-severity missing authorization vulnerability in Apache Activemq, published on 30 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Authorization vulnerability in Apache ActiveMQ.

An authenticated low-privilege Web Console user by default can access /admin/* paths in the Web Console. The default Jetty settings incorrectly did not limit those paths to only admins.
This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7.

Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-49877?

1 open source package ship an affected version, including activemq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activemq` | Bitnami | All versions | 5.19.8, 6.2.7 |

Products: Apache Activemq.

## How do I fix CVE-2026-49877?

Upgrade activemq to a fixed version for your release line: 5.19.8 or 6.2.7.

## Is CVE-2026-49877 being exploited?

There is no known exploitation of CVE-2026-49877 in the wild and no public exploit code.

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49877 and fix it if it is affected.

What it is: CVE-2026-49877 is a high-severity missing authorization vulnerability in Apache Activemq, published on 30 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49877 in the wild and no public exploit code.

Affected packages and fixed versions:
- activemq (Bitnami): affected all versions; fixed in 5.19.8, 6.2.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49877/ (Markdown: https://insights.sbomify.com/CVE-2026-49877/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49877
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49877
- OSV: https://osv.dev/vulnerability/CVE-2026-49877

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49877/
Summaries are generated and may contain mistakes; the official description above is the record.
