# CVE-2026-49970: Laravel-Mediable < 7.0.0 Path Traversal via File::sanitizePath()

> Attackers can exploit path traversal in Laravel-Mediable to upload files to sensitive locations, potentially enabling remote code execution.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jul 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-xv8g-76mx-2rxc

## What is CVE-2026-49970?

CVE-2026-49970 is a high-severity path traversal vulnerability in plank laravel-mediable, published on 13 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Laravel-Mediable before 7.0.0 contains a path traversal vulnerability in the File::sanitizePath() function that allows attackers to write uploaded files to arbitrary locations by controlling the directory argument passed to MediaUploader::toDestination(). Attackers can exploit the permissive character-class regex that allows both dot and slash characters combined with an ineffective trailing trim() call to bypass sanitization and upload files to sensitive locations such as the document root, environment configuration files, or application configuration directories, enabling remote code execution.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-49970?

2 open source packages ship an affected version, including plank/laravel-mediable.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plank/laravel-mediable` | Packagist | All versions | 7.0.0 |
| `plank/laravel-mediable` | Packagist | All versions | 7.0.0 |

## How do I fix CVE-2026-49970?

Upgrade plank/laravel-mediable to 7.0.0 or later.

## Is CVE-2026-49970 being exploited?

There is no known exploitation of CVE-2026-49970 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49970 and fix it if it is affected.

What it is: CVE-2026-49970 is a high-severity path traversal vulnerability in plank laravel-mediable, published on 13 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49970 in the wild and no public exploit code.

Affected packages and fixed versions:
- plank/laravel-mediable (Packagist): affected all versions; fixed in 7.0.0
- plank/laravel-mediable (Packagist): affected all versions; fixed in 7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49970/ (Markdown: https://insights.sbomify.com/CVE-2026-49970/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49970
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49970
- OSV: https://osv.dev/vulnerability/CVE-2026-49970

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49970/
Summaries are generated and may contain mistakes; the official description above is the record.
