CVE-2026-49976 Snipe-IT: User Account Escalation via CSV Import
A user with import permissions can escalate privileges by overwriting another user's email via CSV import to take over their account.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-49976?
CVE-2026-49976 is a medium-severity vulnerability in Snipeitapp Snipe-It, published on 19 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Snipe-IT is an IT asset/license management system. Prior to 8.6.1, a user with the import permission can use CSV update mode to overwrite the email address of a non-admin user and then request a password reset to take over that account. app/Importer/UserImporter.php applies the canEditAuthFields gate by unsetting username, email, password, and activated on the model, but app/Importer/ItemImporter.php sanitizeItemForUpdating() rebuilds the update array from the raw CSV row in $this->item, restoring the unauthorized values. The app/Http/Controllers/ImportController.php import path checks import permission but does not require users.edit. This issue is fixed in version 8.6.1.
Weakness: CWE-863
Which versions are affected by CVE-2026-49976?
2 open source packages ship an affected version, including snipe/snipe-it. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
snipe/snipe-it Packagist | All versions | 8.6.0 |
snipe/snipe-it Packagist | All versions | 8.6.0 |
Products include Snipeitapp Snipe-It.
How do I fix CVE-2026-49976?
Upgrade snipe/snipe-it to 8.6.0 or later.
Is CVE-2026-49976 being exploited?
There is no known exploitation of CVE-2026-49976 in the wild and no public exploit code.
Other vulnerabilities in Snipeitapp Snipe-It
- CVE-2025-63601 File upload in n/a
- CVE-2026-37709 Snipe-IT has insecure permissions in file uploads
- CVE-2026-86738 Snipe-IT before 8.7.0 CSS Injection via Custom CSS
- CVE-2026-116199 Snipe-IT before 8.6.3 Authentication Bypass via Google SSO Callback
- CVE-2022-1380 Stored Cross Site Scripting vulnerability in Item name parameter in snipe/snipe-it
Sources
Also known as GHSA-p68w-rgmg-3c2v.