# CVE-2026-49980: Rclone: Unauthenticated command execution in `rclone rcd --rc-serve` via inline remote instantiation, bypassing CVE-2026-41179 fix


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 24 Jun 2026
- **Updated:** 10 Aug 2026
- **Also known as:** BIT-rclone-2026-49980, DEBIAN-CVE-2026-49980, GHSA-qw24-gh76-8rvv, GO-2026-5596, MINI-9g87-6gv6-v4rr, MINI-p32m-rqqr-fgrm, MINI-pwh4-q2gh-8qgc, MINI-r4pp-2prj-2w58, MINI-wcc9-j593-jhw6, MINI-x85j-gf3f-fgvg, ROOT-APP-GOBINARY-CVE-2026-49980, UBUNTU-CVE-2026-49980, USN-8782-1

## What is CVE-2026-49980?

CVE-2026-49980 is a critical vulnerability in rclone, published on 24 Jun 2026. 

### Official description

Rclone is a command-line program to sync files and directories to and from different cloud storage providers. From 1.46.0 until 1.74.3, rclone rcd --rc-serve accepts unauthenticated GET and HEAD requests to paths of the form: /[remote:path]/object. The remote value is parsed from the URL and passed to normal backend initialization. Inline remote configuration can set backend options that execute local commands during initialization. As a result, a single unauthenticated GET or HEAD request can execute a command as the rclone process user. This vulnerability is fixed in 1.74.3.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-49980?

5 open source packages ship an affected version, including github.com/rclone/rclone, rclone and github.com/ncw/rclone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rclone/rclone` | Go | From 1.46.0 | 1.74.3 |
| `github.com/rclone/rclone` | Go | From 1.46.0 | 1.74.3 |
| `github.com/rclone/rclone` | Go | From 1.49.0 | 1.74.3 |
| `rclone` | Bitnami | From 1.46.0 | 1.74.3 |
| `github.com/ncw/rclone` | Go | From 1.46.0 | None |

Products: Rclone Rclone.

## How do I fix CVE-2026-49980?

Upgrade github.com/rclone/rclone to 1.74.3 or later.

## Is CVE-2026-49980 being exploited?

There is no known exploitation of CVE-2026-49980 in the wild and no public exploit code.

## Other vulnerabilities in rclone

- [CVE-2026-88018](https://insights.sbomify.com/CVE-2026-88018/): rclone serve s3: --auth-proxy without --auth-key authenticates nobody - full SigV4 signature bypass (critical 9.8)
- [CVE-2026-41179](https://insights.sbomify.com/CVE-2026-41179/): RClone: Unauthenticated operations/fsinfo allows attacker-controlled backend instantiation and local command execution (critical 9.2)
- [CVE-2026-41176](https://insights.sbomify.com/CVE-2026-41176/): Rclone: Unauthenticated options/set allows runtime auth bypass, leading to sensitive operations and command execution (critical 9.2)
- [CVE-2026-59733](https://insights.sbomify.com/CVE-2026-59733/): rclone `serve restic --private-repos` authorization bypass: `..` in the URL path lets an authenticated user read, overwrite and delete other users' repositories (high 8.8)
- [CVE-2026-116191](https://insights.sbomify.com/CVE-2026-116191/): Rclone before 1.75.2 Path Traversal via serve webdav MKCOL (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49980 and fix it if it is affected.

What it is: CVE-2026-49980 is a critical vulnerability in rclone, published on 24 Jun 2026. 
Exploitation: There is no known exploitation of CVE-2026-49980 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rclone/rclone (Go): affected from 1.46.0; fixed in 1.74.3
- github.com/rclone/rclone (Go): affected from 1.46.0; fixed in 1.74.3
- github.com/rclone/rclone (Go): affected from 1.49.0; fixed in 1.74.3
- rclone (Bitnami): affected from 1.46.0; fixed in 1.74.3
- github.com/ncw/rclone (Go): affected from 1.46.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49980/ (Markdown: https://insights.sbomify.com/CVE-2026-49980/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49980
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49980
- OSV: https://osv.dev/vulnerability/CVE-2026-49980

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49980/
Summaries are generated and may contain mistakes; the official description above is the record.
