# CVE-2026-49987: Repomix: Command Injection (RCE) via `--remote-branch` Argument Injection

> Attackers can execute arbitrary commands by injecting Git options via the remote branch argument in Repomix.

- **Severity:** High 7.5 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-9mm9-rqhj-j5mx

## What is CVE-2026-49987?

CVE-2026-49987 is a high-severity command injection vulnerability in yamadashy repomix, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Repomix is a tool that packs repositories into AI-friendly files. Prior to 1.14.1, src/core/git/gitCommand.ts execGitShallowClone passes the --remote-branch value directly to git fetch and git checkout without validation or --end-of-options, allowing --upload-pack or other Git option injection that bypasses validateGitUrl() dangerous parameter checks and can execute commands through local or SSH-style transports. This issue is fixed in version 1.14.1.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2026-49987?

2 open source packages ship an affected version, including repomix. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `repomix` | npm | All versions | 1.14.1 |
| `repomix` | npm | All versions | 1.14.1 |

Products: Yamadashy Repomix.

## How do I fix CVE-2026-49987?

Upgrade repomix to 1.14.1 or later.

## Is CVE-2026-49987 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49987 exists.

## Other vulnerabilities in yamadashy repomix

- [CVE-2026-49988](https://insights.sbomify.com/CVE-2026-49988/): Repomix: attach_packed_output can bypass file-read secret scanning for supported local files (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49987 and fix it if it is affected.

What it is: CVE-2026-49987 is a high-severity command injection vulnerability in yamadashy repomix, published on 15 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49987 exists.

Affected packages and fixed versions:
- repomix (npm): affected all versions; fixed in 1.14.1
- repomix (npm): affected all versions; fixed in 1.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49987/ (Markdown: https://insights.sbomify.com/CVE-2026-49987/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49987
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49987
- OSV: https://osv.dev/vulnerability/CVE-2026-49987

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49987/
Summaries are generated and may contain mistakes; the official description above is the record.
