# CVE-2026-49988: Repomix: attach_packed_output can bypass file-read secret scanning for supported local files

> Attackers can bypass secret scanning to read arbitrary local files via the Repomix MCP server, exposing sensitive data.

- **Severity:** Medium 6.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2026
- **Updated:** 18 Jul 2026
- **Also known as:** GHSA-hwpp-h97w-2h3j

## What is CVE-2026-49988?

CVE-2026-49988 is a medium-severity vulnerability in yamadashy repomix, published on 15 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Repomix is a tool that packs repositories into AI-friendly files. Prior to 1.14.1, the Repomix MCP server attach_packed_output and read_repomix_output flow can register and read arbitrary local .json, .txt, .md, or .xml files without the file_system_read_file runSecretLint() safety check or Repomix packed-output validation, allowing MCP callers to bypass the local file-read secret-scanning boundary. This issue is fixed in version 1.14.1.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-49988?

2 open source packages ship an affected version, including repomix. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `repomix` | npm | All versions | 1.14.1 |
| `repomix` | npm | All versions | 1.14.1 |

Products: Yamadashy Repomix.

## How do I fix CVE-2026-49988?

Upgrade repomix to 1.14.1 or later.

## Is CVE-2026-49988 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49988 exists.

## Other vulnerabilities in yamadashy repomix

- [CVE-2026-49987](https://insights.sbomify.com/CVE-2026-49987/): Repomix: Command Injection (RCE) via `--remote-branch` Argument Injection (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49988 and fix it if it is affected.

What it is: CVE-2026-49988 is a medium-severity vulnerability in yamadashy repomix, published on 15 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49988 exists.

Affected packages and fixed versions:
- repomix (npm): affected all versions; fixed in 1.14.1
- repomix (npm): affected all versions; fixed in 1.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49988/ (Markdown: https://insights.sbomify.com/CVE-2026-49988/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49988
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49988
- OSV: https://osv.dev/vulnerability/CVE-2026-49988

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49988/
Summaries are generated and may contain mistakes; the official description above is the record.
