# CVE-2026-49992: Kimai: Login CSRF in Default Team Creation Endpoints Allows Unauthorized Team and Permission Structure Changes

> Attackers can trick logged-in users into modifying team structures and permissions via CSRF in Kimai time tracking application.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-pgcc-vfmc-7cw5

## What is CVE-2026-49992?

CVE-2026-49992 is a medium-severity vulnerability in kimai, published on 11 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Kimai is an open-source time tracking application. Versions prior to 2.58.0 contain authenticated cross-site request forgery issues in their default team creation shortcuts for projects, customers, and activities. These endpoints are exposed through `GET` routes and directly create or reuse a `Team`, add the current user as teamlead, and bind the target object to that team. As a result, an attacker can trick a logged-in user with the required permissions into visiting a malicious page and cause unauthorized changes to team, teamlead, and object-binding relationships. This is a real authorization-structure modification issue rather than a harmless UI shortcut. Version 2.58.0 patches the issue.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-49992?

2 open source packages ship an affected version, including kimai/kimai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kimai/kimai` | Packagist | All versions | 2.58.0 |
| `kimai/kimai` | Packagist | All versions | 2.58.0 |

## How do I fix CVE-2026-49992?

Upgrade kimai/kimai to 2.58.0 or later.

## Is CVE-2026-49992 being exploited?

There is no known exploitation of CVE-2026-49992 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49992 and fix it if it is affected.

What it is: CVE-2026-49992 is a medium-severity vulnerability in kimai, published on 11 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-49992 in the wild and no public exploit code.

Affected packages and fixed versions:
- kimai/kimai (Packagist): affected all versions; fixed in 2.58.0
- kimai/kimai (Packagist): affected all versions; fixed in 2.58.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49992/ (Markdown: https://insights.sbomify.com/CVE-2026-49992/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49992
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49992
- OSV: https://osv.dev/vulnerability/CVE-2026-49992

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49992/
Summaries are generated and may contain mistakes; the official description above is the record.
